Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159402 - Too many kernels
Summary: Too many kernels
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-02 13:53 UTC by Need Real Name
Modified: 2014-01-21 22:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-19 06:44:31 UTC


Attachments (Terms of Use)

Description Need Real Name 2005-06-02 13:53:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Epiphany/1.6.3

Description of problem:
Running Transaction
  Installing: kernel-smp                   ######################### [1/2]
error: unpacking of archive failed on file /boot/System.map-2.6.11-1.1366_FC4smp;429f0ea6: cpio: write

My boot partition is 100 megabytes, and it's full. I have 22 kernels installed.

Please can there be an option in /etc/sysconfig/kernel to specify the number of old kernels to keep?
Also, since the boot partition is normally quite small, can the preinstall script check disk space?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:

Comment 1 Dave Jones 2005-06-02 21:44:05 UTC
Anything involving package removal pretty much has to be done in the updating
tools (ie, yum/up2date). Theres just too many things that can go wrong if the
%post of the kernel started removing other RPMs.


Comment 2 Seth Vidal 2005-06-03 07:07:22 UTC
So here's a neat trick:
http://devel.linux.duke.edu/cgi-bin/viewcvs.cgi/yum-utils/package-cleanup.py?rev=1.2&view=auto


This is one of a set of scripts that will be coming out as 'yum-utils'
They should let you easily clean up old kernels w/o risk to your system, well,
in theory. :)


Comment 3 Need Real Name 2005-06-03 10:46:30 UTC
Cool :)

One thing I noticed (I only skimmed the code)..
If a user manually chooses a non-smp kernel from the grub boot menu, but the
default kernel line in /etc/sysconfig/kernel is kernel-smp, then the "running
kernel check" won't handle accidentally removing the default kernel.

Comment 4 Seth Vidal 2005-06-03 21:05:41 UTC
Yah - okay - so refile the bug or post to yum-devel about that subject, please.

it's not really easy to track for the package-cleanup developers, here.

Comment 5 Rahul Sundaram 2005-06-19 02:47:11 UTC


Should be closed now as package-cleanup is part of yum-utils which is Fedora
Extras repository enabled by default in FC4 and above

Comment 6 Seth Vidal 2005-06-19 06:44:31 UTC
Agreed, closing.

thanks


Comment 7 Need Real Name 2005-06-20 14:13:40 UTC
(In reply to comment #4)
> Yah - okay - so refile the bug or post to yum-devel about that subject, please.
> 
> it's not really easy to track for the package-cleanup developers, here.

Where should I refile the bug? There is no yum-utils package in bugzilla for
either Fedora Extras or Fedora.

Comment 8 Seth Vidal 2005-06-21 06:20:29 UTC
I've requested the components be created.
they will be made soon.



Note You need to log in before you can comment on or make changes to this bug.