Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159390 - disklessrc fail if more than one pci network cards are installed
Summary: disklessrc fail if more than one pci network cards are installed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-netboot
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-02 11:41 UTC by ulrich
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 0.1.18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-25 10:05:04 UTC


Attachments (Terms of Use)

Description ulrich 2005-06-02 11:41:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041122 Firefox/1.0

Description of problem:
disklessrc fails in sub findhardware when multiple (2 in my case)
pci network cards are installed. the problem is the line IFS="\n".
this does not work as expected. changing the line to IFS=$'\n' fixed it for me.

*** disklessrc.rpmorig  2005-05-27 22:06:29.000000000 +0200
--- disklessrc  2005-06-01 19:08:17.000000000 +0200
***************
*** 55,61 ****
          MODULE=""

        IFSOLD=$IFS
!         IFS="\n"
          for CARDLIST in `lspci -n | grep "Class $CLASSNUM"`; do
          {
              PCIID=`echo $CARDLIST | cut -d ' ' -f 4 | sed -e 's/:/    0x/'` &&
--- 55,61 ----
          MODULE=""

        IFSOLD=$IFS
!         IFS=$'\n'
          for CARDLIST in `lspci -n | grep "Class $CLASSNUM"`; do
          {
              PCIID=`echo $CARDLIST | cut -d ' ' -f 4 | sed -e 's/:/    0x/'` &&

Version-Release number of selected component (if applicable):
system-config-netboot-0.1.16-1_FC3

How reproducible:
Always

Steps to Reproduce:
1. install 2 pci network cards on a diskless workstation
2. use system-config-netboot to create a diskless netboot system.
3. boot the diskless workstation
  

Additional info:

Comment 1 Jason Vas Dias 2005-06-08 22:36:03 UTC
Thanks for pointing this out - none of my test boot clients had 
multiple interfaces :( 
This has now been fixed with system-config-netboot-0.1.17-1EL3 ,
soon to be in fc3-updates, and which meanwhile can be downloaded from:
   http://people.redhat.com/~jvdias/system-config-netboot
Please try it out and let me know of any issues - thanks.



Comment 4 Walter Justen 2005-08-25 10:05:04 UTC
Thanks for the bug report. This particular bug was fixed and a update package
was published for download. Please feel free to report any further bugs you find.


Note You need to log in before you can comment on or make changes to this bug.