Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159387 - newgrp resets LD_LIBRAY_PATH variable
Summary: newgrp resets LD_LIBRAY_PATH variable
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: util-linux
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-02 09:29 UTC by Stefan Rystedt
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-16 09:27:25 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Stefan Rystedt 2005-06-02 09:29:34 UTC
Description of problem:
The newgrp commands resets the LD_LIBRARY_PATH variable.
This wreck havocs with many of the scripts we are using today.
It does not do that in solaris version of newgrp. Is this an
intended featur or a bug?

Version-Release number of selected component (if applicable):
util-linux-2.11y-31.1

How reproducible:
always

Steps to Reproduce:
1. Set LD_LIBRARY_PATH
2. run newgrp
3. echo LD_LIBRAY_PATH and se that it is undefined
  
Actual results:
LD_LIBRARY_PATH gets undefined.

Expected results:
LD_LIBRARY_PATH should keep its value.

Comment 1 Karel Zak 2005-06-02 12:50:25 UTC
-rws--x--x  1 root root 10112 Dec 21 21:43 /usr/bin/newgrp
   ^
 it's feature


Note You need to log in before you can comment on or make changes to this bug.