Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159382 - NAMELEN too short in sgml stylesheet
Summary: NAMELEN too short in sgml stylesheet
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: docbook-dtds
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 317961
TreeView+ depends on / blocked
 
Reported: 2005-06-02 06:42 UTC by Devrim Gündüz
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: 1.0-28
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-13 08:32:41 UTC


Attachments (Terms of Use)

Description Devrim Gündüz 2005-06-02 06:42:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
The various DocBook DTDs set a NAMELEN constant that is too short for many
purposes It is 44 now since years, and it should be set to a higher value; such as 256.

If you grep NAMELEN `find /usr/share/sgml -name "*"` and change all "44" to
something larger it will fix the problem. 

Version-Release number of selected component (if applicable):
docbook-dtds-1.0-25

How reproducible:
Always

Steps to Reproduce:
1. Try using a name field larger than 44 in an sgml file.
2.
3.
  

Additional info:

Comment 1 Devrim Gündüz 2005-06-02 09:33:53 UTC
There is also another bug info for RH 7.1, reported by Havoc Pennington:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=36058

Comment 2 Tim Waugh 2005-06-02 13:07:30 UTC
Fixed in Fedora development, and so the next full release of Red Hat Enterprise
Linux will pick up the change.  I don't think this problem warrants an updated
package.

Comment 3 Devrim Gündüz 2005-06-02 13:14:43 UTC
There are many apps around that is experiencing problems with the NAMELEN issue,
like Slony-I: http://www.slony.info.

It's really not hard to keep it up with Fedora Core, but playing with RHEL is
not nice. As an RPM developer, I manually bump up the NAMELEN values, but I
don't think that all users can do this.

BTW, are you planinng a backpatch to FC 3?


Comment 4 Devrim Gündüz 2005-06-02 13:15:42 UTC
(In reply to comment #2)
> Fixed in Fedora development, and so the next full release of Red Hat Enterprise
> Linux will pick up the change.  I don't think this problem warrants an updated
> package.

There are many apps around that is experiencing problems with the NAMELEN issue,
like Slony-I: http://www.slony.info.

It's really not hard to keep it up with Fedora Core, but playing with RHEL is
not nice. As an RPM developer, I manually bump up the NAMELEN values, but I
don't think that all users can do this.

So, we *really* need an updated package. This *bug* exists since 7.1, so we
deserve an update.

BTW, are you planinng a backpatch to FC 3?

Comment 5 Brendan O'Dea 2005-10-13 02:09:23 UTC
The 1.0-27 package still has "NAMELEN 44".  You need to change the regex used in
the substitution (sed doesn't match WS with \s).  Something like this works:

  # Increase NAMELEN (bug #36058, bug #159382).
  sed -e's,\(NAMELEN[ \t]\+\)44\>$,\1256,' -i.namelen */docbook.dcl

Comment 6 Brendan O'Dea 2005-10-13 02:12:46 UTC
Ooop, drop the '$'...

Comment 7 Tim Waugh 2005-10-13 08:32:27 UTC
Sed certainly does match WS with \s -- and you are right that the $ was causing
the problem.  There is whitespace at the end of the line in the original file(!).

Thanks, fixed.

Comment 8 Dave Botsch 2007-10-03 19:06:37 UTC
Hi, guys. Stuff such as slony can't be built on rhel4 due to this issue. Please
fix in RHEL4. Thanks.


Note You need to log in before you can comment on or make changes to this bug.