Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159377 - anaconda prevents the cciss module from unloading
Summary: anaconda prevents the cciss module from unloading
Keywords:
Status: CLOSED DUPLICATE of bug 157622
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-02 04:04 UTC by Con Tassios
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-07 20:16:12 UTC


Attachments (Terms of Use)

Description Con Tassios 2005-06-02 04:04:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050519 Firefox/1.0.4

Description of problem:
I use the %pre section in kickstart scripts to create RAID volumes on HP SmartArray controllers using the HP hpacucli utility. In order for the cciss driver to read the new controller configuration, the cciss module must be reloaded.

On RHEL3, an 'rmmod cciss' is successful, but on RHEL4 the module cannot be unloaded because it is in use.  It appears that anaconda is holding this resource preventing cciss from being removed.  The 'Used by' column in lsmod shows the count equivalent to the number of logical drives presented by the controller at bootup.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rmmod cciss in %pre section of kickstart script
2.
3.
  

Actual Results:  cciss module fails to unload as it is in use

Expected Results:  module should unload.

Additional info:

Comment 1 Jeremy Katz 2005-06-07 19:45:38 UTC
anaconda isn't doing anything to keep devices open.  But rmmod for modules isn't
guaranteed... it's possible that this is occurring within the cciss driver.

Comment 2 Jeremy Katz 2005-06-07 20:16:12 UTC

*** This bug has been marked as a duplicate of 157622 ***


Note You need to log in before you can comment on or make changes to this bug.