Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159372 - spin_lock panic in IDE autotuning
Summary: spin_lock panic in IDE autotuning
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alan Cox
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-02 00:38 UTC by Bryce
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 2.6.11-1.14_FC3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-08 13:29:49 UTC


Attachments (Terms of Use)
Spin_lock crash (deleted)
2005-06-02 00:38 UTC, Bryce
no flags Details
Section of code involved (deleted)
2005-06-02 00:40 UTC, Bryce
no flags Details
Possible fix (deleted)
2005-07-11 09:30 UTC, Alan Cox
no flags Details | Diff

Description Bryce 2005-06-02 00:38:02 UTC
Description of problem:

spinlock panic

Version-Release number of selected component (if applicable):
2.6.11-1.27_FC3

How reproducible:

on reboot every now and then

I can tell you exactly whats happening
Observe the two attached images
one shows the panic and the other is a screenshot of the code involved

notice the two spin_lock_irqsave()'s
Whats happening is simple, when there is a reset of the drive it invokes a
restore of timings. This is part of auto tuning, so it is obvious you get a
double lock down, hence the spinlock crash.

Phil
=--=

Comment 1 Bryce 2005-06-02 00:38:59 UTC
Created attachment 115072 [details]
Spin_lock crash

Crash on reboot

Comment 2 Bryce 2005-06-02 00:40:09 UTC
Created attachment 115073 [details]
Section of code involved

The red cursors identify the code lines involved

Comment 3 Bryce 2005-06-02 01:27:07 UTC
Incidentally this arises from the mainline 2.6.11 kernel source and isn't the
result of any patchs that are added to the kernel by RHAT

Phil
=--=

Comment 4 Alan Cox 2005-07-11 09:28:27 UTC
Umm yes. Does the attachment I'll add fix it ?


Comment 5 Alan Cox 2005-07-11 09:30:14 UTC
Created attachment 116592 [details]
Possible fix

Comment 6 Dave Jones 2005-07-15 19:14:51 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 7 Bryce 2005-09-08 13:29:49 UTC
Seems to be fixed (it was a every now and then bug in the first place) I've not
seen it for quite some time so I think this is fixed.

Cheers

Phil
=--=


Note You need to log in before you can comment on or make changes to this bug.