Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159371 - Build assumes that you have 'gmake' installed
Summary: Build assumes that you have 'gmake' installed
Keywords:
Status: CLOSED DUPLICATE of bug 210736
Alias: None
Product: 389
Classification: Retired
Component: Install/Uninstall
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nathan Kinder
QA Contact: Orla Hegarty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-02 00:16 UTC by William Lachance
Modified: 2007-04-18 17:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-25 02:34:33 UTC


Attachments (Terms of Use)

Description William Lachance 2005-06-02 00:16:51 UTC
Description of problem: Build assumes that you have 'gmake' installed


Version-Release number of selected component (if applicable):
FedoraDS71_20050526_RTC.


How reproducible:
Always


Steps to Reproduce:
On a Debian system, start building ldapserver from the root directory by typing
'make USE_PERL_FROM_PATH=1'. 
  
Actual results:

Will complain very quickly about not being able to find the 'gmake' binary.
Making a symlink from '/usr/bin/gmake' to '/usr/bin/make' fixes the problem.

Expected results:

Build should execute from start to finish.

Additional info:

Probably should have a configure (autoconf) script which checks to see if gmake
is installed, and use it for the entire build process if it exists, and use
standard make otherwise.

Comment 2 Rich Megginson 2005-12-01 17:03:44 UTC
Is this still a problem with FDS 1.0 - try
http://directory.fedora.redhat.com/sources/dsbuild-fds10.tar.gz

Comment 3 Nathan Kinder 2006-10-25 02:34:33 UTC
An autoconf and automake build system has been implemented for Fedora DS which
takes care of this issue.  I'm marking this as a duplicate of the bug used to
implement the new build system.

*** This bug has been marked as a duplicate of 210736 ***


Note You need to log in before you can comment on or make changes to this bug.