Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159360 - /sbin/stinit execution causes syslog error message
Summary: /sbin/stinit execution causes syslog error message
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mt-st
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-01 21:35 UTC by Jim Waldram
Modified: 2013-07-02 23:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-14 12:35:31 UTC


Attachments (Terms of Use)

Description Jim Waldram 2005-06-01 21:35:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.7.8-1.4.1

Description of problem:
Execution /sbin/stinit to initialize a tape drive causes the following to be logged in /var/log/messages:
kernel: program stinit is using a deprecated SCSI ioctl, please convert it to SG_IO

Version-Release number of selected component (if applicable):
mt-st-0.8-1

How reproducible:
Always

Steps to Reproduce:
1./sbin/stinit
2.tail /var/log/messages
3.
  

Actual Results:  reported kernel messages is generated

Expected Results:  no message

Additional info:

Comment 1 Jindrich Novy 2005-06-02 13:32:50 UTC
I cannot see anything when /sbin/stinit is called in /var/log/messages/. The
possible reason for this that I use RHEL4 U1 kernel, uname -a says:

Linux 2.6.9-11.ELsmp #1 SMP Fri May 20 18:25:30 EDT 2005 x86_64 x86_64 x86_64
GNU/Linux

Which kernel do you use?

Comment 2 Jim Waldram 2005-06-02 15:00:17 UTC
uname -a
Linux nutria.uwyo.edu 2.6.9-5.0.5.EL #1 Fri Apr 8 14:21:35 EDT 2005 i686 athlon
i386 GNU/Linux
same results on another system:
uname -a
Linux xxx....uwyo.edu 2.6.9-5.0.3.ELsmp #1 SMP Mon Feb 14 10:03:50 EST 2005 i686
i686 i386 GNU/Linux

/etc/stinit.def:
# Exabyte 8505 and other similar 8 mm helical scan driver
manufacturer=EXABYTE model = "EXB-8505" {
scsi2logical=1 can-bsr auto-lock
mode1 blocksize=0 density=0x8c  # 8500 density, compressing
mode2 blocksize=0 density=0x15  # 8500 density, no compression
mode3 blocksize=0 density=0x90  # 8200 density, compressing
mode4 blocksize=0 density=0x14  # 8200 density, no compression
}

-rwxr-xr-x  1 root root 33480 Aug  9  2004 /sbin/stinit

This is a newly installed RHEL 4 system.  Up2date.

/etc/syslog.conf logging for /var/log/messages:
*.info;mail.none;news.none;auth.none;authpriv.none;cron.none           
/var/log/messages

Comment 3 Jindrich Novy 2005-06-08 08:58:45 UTC
I tried to reproduce your case on both RHEL4 U1 and RHEL4 systems with exactly
the same configuration as you presented in comment #2. The problem is that I'm
unable to make stinit actually running as it requires a tape drive actually
installed on my system to let stinit communicate using the deprecated SCSI ioctl.

I get:
# /sbin/stinit
Initialized 0 tape devices.

Maybe a look into the mt-st code will give me some clue.


Comment 4 Jim Waldram 2006-08-04 19:04:36 UTC
After a "flag" change to the bug, I have reviewed.  At:
2.6.9-34.0.2.ELsmp #1 SMP Fri Jun 30 10:33:58 EDT 2006 i686 i686 i386 GNU/Linux
for several systems that are RHN current, the error message is no longer generated.
I would assume that you found the offending code and got it updated.
I did/do not see a resolution in the bugzilla bug record and thought an update
on a year old bug might be appropriate.
I consider the problem resolved at current revisions.

Comment 6 Jindrich Novy 2006-09-14 12:35:31 UTC
Ok, closing NOATBUG as the problem is now resolved in the current releases.


Note You need to log in before you can comment on or make changes to this bug.