Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159358 - [PATCH] xterm creates two utmp entries on entry and only removes one on exit
Summary: [PATCH] xterm creates two utmp entries on entry and only removes one on exit
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: xterm
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard: RHEL3U7NAK
Depends On:
Blocks: 187539
TreeView+ depends on / blocked
 
Reported: 2005-06-01 21:28 UTC by David Lehman
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHBA-2006-0422
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-05-10 21:30:19 UTC


Attachments (Terms of Use)
Don't manually create utmp/wtmp entries if using utempter (deleted)
2005-06-01 21:28 UTC, David Lehman
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0422 normal SHIPPED_LIVE xterm bug fix update 2006-07-19 20:40:00 UTC

Description David Lehman 2005-06-01 21:28:07 UTC
Description of problem:
xterm has code to create utmp entries using utempter and manually. The code to
clean up the utmp entries on logout/exit is conditionalized on whether or not
it's configured to use utempter. The code to manually create utmp entries is not
correspondingly conditionalized and so whenever xterm exits it leaves behind a
stale/dummy utmp entry. 

Version-Release number of selected component (if applicable):
xterm-179-5.EL

How reproducible:
Always

Steps to Reproduce:
1. run who -u
2. open an xterm
3. run who -u (you'll see two new entries for the xterm)
4. close the xterm any way you like
5. run who -u 

Actual results:
Only one of the xterm entries will be gone (the one created by utempter).

Expected results:
Only one utmp entry created in the first place; if there are multiple entries
created I'd expect them to all be removed on exit.

Additional info:

Comment 1 David Lehman 2005-06-01 21:28:07 UTC
Created attachment 115065 [details]
Don't manually create utmp/wtmp entries if using utempter

Comment 2 Thomas E. Dickey 2005-08-07 21:56:13 UTC
This was part of the changes for xterm patch #188.

Comment 6 Jason Vas Dias 2005-11-29 20:15:53 UTC
This bug is now fixed with xterm-179-6.EL3 (patch applied) .


Comment 8 Daniel Riek 2006-03-24 15:59:50 UTC
A fix to this issue seems to be available and it is not unlikely that this
component will be included in a future Update release. 

Moving to the next Update, clearing all ACKs.

Comment 14 Red Hat Bugzilla 2006-05-10 21:30:19 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0422.html



Note You need to log in before you can comment on or make changes to this bug.