Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159351 - SHPCHP driver doesn't program _HPP values and enable PERR and SERR properly
Summary: SHPCHP driver doesn't program _HPP values and enable PERR and SERR properly
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Keiichiro Tokunaga
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 176344
TreeView+ depends on / blocked
 
Reported: 2005-06-01 20:30 UTC by David Milburn
Modified: 2007-11-30 22:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-11 15:32:54 UTC


Attachments (Terms of Use)
Upstream patch to enable PERR and SERR. (deleted)
2005-06-01 20:31 UTC, David Milburn
no flags Details | Diff
Upstream patch to program _HPP values properly. (deleted)
2005-06-01 20:32 UTC, David Milburn
no flags Details | Diff

Description David Milburn 2005-06-01 20:30:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
SHPCHP driver doesn't program command register to 
enable PERR and SERR properly, and doesn't program
_HPP values properly.

Version-Release number of selected component (if applicable):
kernel-2.6.9-5.0.3.EL-ia64

How reproducible:
Always

Steps to Reproduce:
1. Hot-add the PCI device onto the SHPC based PCI hotplug slot.
2.
3.
  

Actual Results:  The following registeres for PCI devices being hot-added will 
not be programed properly.
  
o Cache Line Size
o Latncy Timer
o SERR
o PERR


Expected Results:  The following registeres for PCI devices being hot-added 
are programed properly.
       
o Cache Line Size
o Latncy Timer
o SERR
o PERR


Additional info:

Attaching 2 patches to fix this problem, both have been 
accepted upstream.

http://sourceforge.net/mailarchive/forum.php?thread_id=7332765&forum_id=765
http://kernel.org/pub/linux/kernel/people/gregkh/gregkh-2.6/gregkh-03-pci/

Comment 1 David Milburn 2005-06-01 20:31:49 UTC
Created attachment 115063 [details]
Upstream patch to enable PERR and SERR.

Comment 2 David Milburn 2005-06-01 20:32:36 UTC
Created attachment 115064 [details]
Upstream patch to program _HPP values properly.

Comment 9 Linda Wang 2006-03-15 20:59:15 UTC
Due to limited engr capacity for U4, will move this to 
U5 prop. 

Comment 14 Keiichiro Tokunaga 2007-02-26 17:35:14 UTC
It has been agreed to defer this bug to 4.6 in it73448.

Comment 17 Luming Yu 2007-08-28 09:20:48 UTC
Is this request still needed?

Comment 19 Luming Yu 2007-08-31 02:46:14 UTC
>1. Hot-add the PCI device onto the SHPC based PCI hotplug slot.

Comment 20 Luming Yu 2007-08-31 02:49:15 UTC
Re: >1. Hot-add the PCI device onto the SHPC based PCI hotplug slot.

It sounds like a generic problem rather than ia64 specific problem.
So I think it make sense to move it to generic hardware category.

Comment 22 Keiichiro Tokunaga 2007-09-11 15:32:54 UTC
Closing this bug as Fujitsu does not request this anymore and there is any other
vendors requesting.


Note You need to log in before you can comment on or make changes to this bug.