Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159324 - libswt3-gtk2 broken softlink and missing bugzilla
Summary: libswt3-gtk2 broken softlink and missing bugzilla
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 159880
TreeView+ depends on / blocked
 
Reported: 2005-06-01 17:19 UTC by John Ellson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 3.1.1-1jpp_1fc.FC4.4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-03 16:09:32 UTC


Attachments (Terms of Use)

Description John Ellson 2005-06-01 17:19:20 UTC
Description of problem:
There is no entry in bugzilla for libswt3-gtk2 so I'll try reporting this
against eclipse. Rpm installs a broken softlink:
  /usr/share/java/swt-gtk-3.1.0_fc.jar ->
/usr/share/eclipse/plugins/org.eclipse.swt.gtk_3.1.0.jar


Version-Release number of selected component (if applicable):
libswt3-gtk2-3.1.0_fc-0.M6.22.x86_64.rpm

How reproducible:


Steps to Reproduce:
1.install from rpm
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Andrew Overholt 2005-06-06 15:10:05 UTC
Hmm.  The relevant line from the specfile is this:

ln -sf
%{_datadir}/%{name}/plugins/org.eclipse.swt.gtk.linux.%{eclipse_arch}_%{eclipse_majmin}.%{eclipse_micro}.jar
swt-gtk-%{eclipse_majmin}.%{eclipse_micro}.jar

Maybe %{eclipse_arch} isn't being set up properly on x86_64?

Comment 2 Andrew Overholt 2005-12-02 20:35:03 UTC
Is this still an issue?

Comment 3 John Ellson 2005-12-03 01:22:09 UTC
The boken softlink has been fixed.

There is still no bugzilla entry for libswt*


Comment 4 Andrew Overholt 2005-12-03 16:09:32 UTC
Thanks.

I don't think there will ever be an entry for libswt* because it's a sub-package
of the Eclipse SRPM and I'm pretty sure that entries are for SRPMs only.  You
could file a bug against the Bugzilla component if you'd like to see this
changed but I'm pretty sure it's automated.

Closing CURRENTRELEASE.

Comment 5 Igor Foox 2006-03-15 16:51:36 UTC
(In reply to comment #1)
>Hmm.  The relevant line from the specfile is this:
>ln -sf
>%{_datadir}/%{name}/plugins/org.eclipse.swt.gtk.linux.%{eclipse_arch}_%{eclipse_majmin}.%{eclipse_micro}.jar
>swt-gtk-%{eclipse_majmin}.%{eclipse_micro}.jar
>Maybe %{eclipse_arch} isn't being set up properly on x86_64?

Wow, nice.


Note You need to log in before you can comment on or make changes to this bug.