Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159277 - Fedora Core 3 64 Bit & Fedora Core 4 RC3 64 Bit : Unbale to install on a athlon 64 Bit Machine.
Summary: Fedora Core 3 64 Bit & Fedora Core 4 RC3 64 Bit : Unbale to install on a athl...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: rawhide
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-01 10:49 UTC by BM Shukla
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-17 17:21:03 UTC


Attachments (Terms of Use)

Description BM Shukla 2005-06-01 10:49:47 UTC
Description of problem: Tried to install Fedora Core 3 64 Bit and Fedora Core 4
RC3 64 bit on one of my Athlon 64Bit PC. This PC has K8 Triton GA-K8VM800M
Mother board. During Installation, Just after Media test, it is unable to detect
the correct Display card & Monitor & Hangs. So I am unable to complete the
installation. In the same machine I installed Fedora Core3 32 Bit Version, It
was able to load X but could not detect the correct Display Adaptor type. It has
onboard VGA VIA K8M800 Chipset.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Mike A. Harris 2005-06-17 17:21:03 UTC
This video hardware is not supported in x86_64 at this time.  You must
perform a text mode installation, and manually configure it to use the
"vesa" driver after install.

The reason for this is that the database that maps video hardware to
a particular driver is shared between all architectures, and does not
have a way to override what driver gets used on a specific architecture.
This means we must map a video card to one single driver, and that gets
used on all architectures even if the driver does not exist on them.  Our
primary architecture is x86, so the default driver mappings are all
x86 specific.

In order to fix this, requires complete reworking of how video hardware
to driver mappings are done, which is a long term level feature enhancement
which will likely be available in a future release of Fedora Core.

For the time being, this problem is not trivially fixable on your hardware
until X.Org officially supports this via chip on x86_64.  If you'd like
to track this problem in X.Org, the upstream bug report is:

https://bugs.freedesktop.org/show_bug.cgi?id=1973



Note You need to log in before you can comment on or make changes to this bug.