Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159273 - OO Calc dies on "Save As..." with new file
Summary: OO Calc dies on "Save As..." with new file
Keywords:
Status: CLOSED DUPLICATE of bug 144607
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-vfs2
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-01 10:33 UTC by Bryn M. Reeves
Modified: 2013-03-06 03:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-01 11:09:50 UTC


Attachments (Terms of Use)
Bugbuddy backtrace from the oocalc crash (deleted)
2005-06-01 10:33 UTC, Bryn M. Reeves
no flags Details

Description Bryn M. Reeves 2005-06-01 10:33:21 UTC
Description of problem:
New oocalc release dies when selecting "Save As" for a new spreadsheet. The
error message when run in a terminal indicates an assertion failure in the
gnome-vfs code:

end from FAM server connection
failed to read() from server connection

libgnomevfs-ERROR **: file gnome-vfs-cancellation.c: line 133
(gnome_vfs_cancellation_cancel): assertion failed: (gnome_vfs_is_primary_thread())

The FAM related messages also appear when this problem is not manifested.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.3-11.5.0.fc3
gnome-vfs2-2.8.2-8

How reproducible:
Happens more than 9 times out of 10. If I sit here running oocalc in a shell
loop, every now and again it will start to work. I can't see any obvious
diference between the app/system state between the failures and successes. Have
not been able to test on another system yet. 

Steps to Reproduce:
1. Start oocalc (from panel icon or terminal) 
2. Select "File" -> "Save As"

  
Actual results:
Application terminates.

Expected results:
Application opens "Save As" dialogue.

Additional info:
Seems like this might be related to BZ151558.

Comment 1 Bryn M. Reeves 2005-06-01 10:33:21 UTC
Created attachment 115019 [details]
Bugbuddy backtrace from the oocalc crash

Comment 2 Caolan McNamara 2005-06-01 11:09:50 UTC

*** This bug has been marked as a duplicate of 144607 ***


Note You need to log in before you can comment on or make changes to this bug.