Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159272 - Wrong permission for external DVD burner device
Summary: Wrong permission for external DVD burner device
Keywords:
Status: CLOSED DUPLICATE of bug 182600
Alias: None
Product: Fedora
Classification: Fedora
Component: udev
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-01 10:32 UTC by David Balažic
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-05-05 14:41:05 UTC


Attachments (Terms of Use)

Description David Balažic 2005-06-01 10:32:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Right clicking a DVD icon and selecting 'Eject' on GNOME desktop gives an error and the medium is
not ejected. (It _is_ unmounted).

More details :

[stein@localhost ~]$ eject /dev/scd0 -v
eject: device name is `/dev/scd0'
eject: expanded name is `/dev/scd0'
eject: `/dev/scd0' is not mounted
eject: `/dev/scd0' is not a mount point
eject: `/dev/scd0' is not a multipartition device
eject: unable to open `/dev/scd0'
[stein@localhost ~]$ ls -l /dev/scd0
brw-r-----  1 root disk 11, 0 May 31 19:51 /dev/scd0
[stein@localhost ~]$ ls -l /dev/hda
brw-------  1 stein disk 3, 0 May 31  2005 /dev/hda



Version-Release number of selected component (if applicable):
udev-057-1

How reproducible:
Always

Steps to Reproduce:
See above.

Additional info:

Comment 1 David Balažic 2005-06-01 10:32:53 UTC
I tried to connect the unit via USB and FireWire. It behaves the same in both cases.

Comment 2 Harald Hoyer 2005-06-06 14:32:31 UTC
$ ls -l /dev/cd*

Comment 3 David Balažic 2005-06-08 07:18:44 UTC
~]$ ls -l /dev/cd*
lrwxrwxrwx  1 root root 3 Jun  8  2005 /dev/cdrom -> hda
lrwxrwxrwx  1 root root 3 Jun  8  2005 /dev/cdrom1 -> hdb
lrwxrwxrwx  1 root root 3 Jun  8  2005 /dev/cdrom2 -> hdc
lrwxrwxrwx  1 root root 4 Jun  7 23:22 /dev/cdrom3 -> scd0
lrwxrwxrwx  1 root root 3 Jun  8  2005 /dev/cdwriter -> hda
lrwxrwxrwx  1 root root 4 Jun  7 23:22 /dev/cdwriter1 -> scd0


I also discovered, that the problem happens only, if I plug in the drive after I
logged in :

 - plugin the drive _before_ boot : ls -l /dev/scd0
brw-------  1 stein disk 11, 0 Jun  7 23:22 /dev/scd0

 - plugin the drive after boot, before login : ls -l /dev/scd0
brw-------  1 stein disk 11, 0 Jun  7 23:35 /dev/scd0

 - plugin the drive after logging in : ls -l /dev/scd0
brw-r-----  1 root disk 11, 0 Jun  7 23:39 /dev/scd0


Comment 4 Harald Hoyer 2006-02-15 13:21:41 UTC
First user who logs in gets all the devices... so you may have to login as an
ordinary user first?

Comment 5 John Thacker 2006-05-05 14:41:05 UTC
Duplicate of 182600.
Fixed by udev-084-13

*** This bug has been marked as a duplicate of 182600 ***


Note You need to log in before you can comment on or make changes to this bug.