Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159263 - Missing xpdf requires
Summary: Missing xpdf requires
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: tetex
Version: rawhide
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-01 05:48 UTC by Michael A. Peters
Modified: 2013-07-02 23:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-01 13:00:35 UTC


Attachments (Terms of Use)

Description Michael A. Peters 2005-06-01 05:48:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
[mpeters@laptop ~]$ texdoc prosper-doc
[mpeters@laptop ~]$ /usr/bin/texdoc: line 193: xpdf: command not found


Version-Release number of selected component (if applicable):
tetex-3.0-4

How reproducible:
Always

Steps to Reproduce:
1. don't install xpdf
2. do install tetex
3. texdoc somepackage-doc
  

Actual Results:  /usr/bin/texdoc: line 193: xpdf: command not found

Expected Results:  If it is going to use xpdf for documentation display, it should require it.

Additional info:

I can understand not wanting X or X dependencies on a server that may have tetex installed, so this is a bug that can be ignored. However, since Fedora is defaulting to evince for pdf document display, perhaps texdoc should look for evince rather than xpdf, as it is more likely to find evince on fc4

Comment 1 Jindrich Novy 2005-06-01 13:00:35 UTC
I see that after installation of tetex-3.0-4, texdoc launches html viewer by
default:

[jnovy@obelix ~]$ texdoc -v latex
(htmlview /home/jnovy/texmf/doc/help/Catalogue/entries/latex.html) 2>/dev/null
|| firefox /home/jnovy/texmf/doc/help/Catalogue/entries/latex.html &

I think it's a bad idea to hardly require xpdf in tetex as there exit other ways
how to read TeX documentation. If we add a xpdf requirement, then we need to add
a handful of other requirements such as firefox, etc.


Note You need to log in before you can comment on or make changes to this bug.