Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159256 - SFTP subsystem doesn't work.
Summary: SFTP subsystem doesn't work.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssh
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-31 21:40 UTC by Ali-Reza Anghaie
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-26 02:02:48 UTC


Attachments (Terms of Use)

Description Ali-Reza Anghaie 2005-05-31 21:40:24 UTC
Description of problem:

SFTP subsystem doesn't work. Fails silently while SCP works fine.

Version-Release number of selected component (if applicable):

openssh-3.9p1-8.RHEL4.1

How reproducible:

Always.

Steps to Reproduce:
1. Just try inbound SFTP on a stock RHEL 4 machine.
2.
3.
  
Actual results:

SFTP inbound fails.

Expected results:

SFTP inbound should work.

Additional info:

All it does is create nice secure log entries like:

May ## ##:##:## hostname sshd[11537]: subsystem request for sftp

And nothing else. The client fails to connect regardless of client. SCP works
fine. No process I can see via ps or top seems to actually be launched on the
server side. Haven't tried tracing or debug mode yet, will update with debug
after I get these mass migrations done via SCP first.

Comment 4 Tomas Mraz 2005-06-06 13:28:25 UTC
I couldn't reproduce this problem here do you have more information? F. E. exact
commands which fail, architecture of the HW, the debugging logs and so on.


Comment 5 Ali-Reza Anghaie 2005-06-26 02:02:48 UTC
The problem seems to be unique to when I'm using a WinSCP client. The logging
shows nothing useful, it just drops. Verbose doesn't help either.... just
*poof*. I haven't captured a session via Ethereal but I'm unsure that's going to
be fruitful. Since it's unique to the WinSCP client (tried various versions
too), I'm closing this bug.


Note You need to log in before you can comment on or make changes to this bug.