Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159248 - traceback while attempting to start IP service
Summary: traceback while attempting to start IP service
Keywords:
Status: CLOSED DUPLICATE of bug 158348
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-31 20:43 UTC by Corey Marthaler
Modified: 2009-04-16 20:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-31 21:07:08 UTC


Attachments (Terms of Use)

Description Corey Marthaler 2005-05-31 20:43:40 UTC
Description of problem:
I dragged and dropped the IP service over morph-03 and then saw this traceback:

Member morph-03.lab.msp.redhat.com trying to enable ip...rhpl.executil waitpid:
No child processes
Traceback (most recent call last):
  File "/usr/share/system-config-cluster/MgmtTab.py", line 230, in onTimer
    if self.model_builder.isClusterMember():
  File "/usr/share/system-config-cluster/ModelBuilder.py", line 402, in
isClusterMember
    return self.command_handler.isClusterMember()
  File "/usr/share/system-config-cluster/CommandHandler.py", line 55, in
isClusterMember
    out, err, res =
rhpl.executil.execWithCaptureErrorStatus("/sbin/magma_tool",args)
  File "/usr/lib/python2.3/site-packages/rhpl/executil.py", line 267, in
execWithCaptureErrorStatus
    if os.WIFEXITED(status) and (os.WEXITSTATUS(status) == 0):
UnboundLocalError: local variable 'status' referenced before assignment
failed


Version-Release number of selected component (if applicable):
-67

How reproducible:
not very, was only able to hit this once.

Comment 1 Corey Marthaler 2005-05-31 21:07:08 UTC

*** This bug has been marked as a duplicate of 158348 ***


Note You need to log in before you can comment on or make changes to this bug.