Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159195 - Hugepages does not get allocated for Oracle 10g
Summary: Hugepages does not get allocated for Oracle 10g
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Larry Woodman
QA Contact: Brian Brock
URL:
Whiteboard:
: 159154 159207 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-31 13:35 UTC by Boris Mironov
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-07 19:44:02 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Boris Mironov 2005-05-31 13:35:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
Oracle 10g database is certified to run on RHEL4 with no changes.
Unfortunately, my system can not use settings that work fine under RHEL3. Namely, I was able to use hugepages.

Under RHEL4 'cat /proc/meminfo' shows no usage of hugepages after Oracle instance starts. At same time a lot of swapping take place.

Version-Release number of selected component (if applicable):
kernel-2.6.9-5.0.5.ELsmp

How reproducible:
Always

Steps to Reproduce:
1. start kernel with hugepages=500 parameter
2. start Oracle 10g
3. 
  

Actual Results:  /proc/meminfo shows no usage of hugepages

Expected Results:  some hugepages should be allocated by Oracle instance

Additional info:

Regarding to numerous postings about SLES9 kernel 2.6 works fine for Oracle inside hugepages

Comment 1 Boris Mironov 2005-05-31 13:36:30 UTC
Hello,

I've filed this problem with Oracle as TAR# 4405454.992

Best regards,
Boris

Comment 2 Boris Mironov 2005-05-31 16:04:00 UTC
*** Bug 159154 has been marked as a duplicate of this bug. ***

Comment 3 Boris Mironov 2005-05-31 16:04:48 UTC
*** Bug 159207 has been marked as a duplicate of this bug. ***

Comment 4 Boris Mironov 2005-05-31 16:06:19 UTC
Hello,

Sorry guys it seems that 'Refresh' button repopulated my bug.

Boris

Comment 5 Boris Mironov 2005-06-06 01:27:16 UTC
Hello,

Oracle forwarded me to Metalink document 262004.1 (Title: Configuring RHEL 3 
and Oracle 9iR2 with Hugetlb and Remap_file_pages). It works for Oracle 10g 
under RHEL 4.

This bug could be closed.

Thanks,
Boris

Comment 6 Suzanne Hillman 2005-06-07 19:44:02 UTC
Closing as per comment #5.


Note You need to log in before you can comment on or make changes to this bug.