Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159194 - sendmail auth wont work with yp(nis) by defualt
Summary: sendmail auth wont work with yp(nis) by defualt
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cyrus-sasl
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
: 146209 176660 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-31 13:29 UTC by Chris Jones
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 2.1.21-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-30 16:01:00 UTC


Attachments (Terms of Use)

Description Chris Jones 2005-05-31 13:29:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050110 Firefox/1.0 (Debian package 1.0+dfsg.1-2)

Description of problem:
/etc/sysconfig/saslauthd sets the defualt authentication mechinism to shaddow, rather than pam, this breaks auth for anyone not useing shadow

MECH=shadow


Version-Release number of selected component (if applicable):
sendmail-8.13.1-2

How reproducible:
Always

Steps to Reproduce:
1. Install sendmail
2. Install yp (nis)
3. Setup sendmail to use auth on sending
4. Try to send mail, useing auth from a valid yp user

Actual Results:  Failed to send mail, with user/password unknown type error

Expected Results:  Mail should have been accepted, as the user is a valid user

Additional info:

Comment 1 Walter Justen 2005-08-26 10:55:39 UTC
*** Bug 146209 has been marked as a duplicate of this bug. ***

Comment 2 Thomas Woerner 2005-08-26 15:37:03 UTC
Assinging to cyrus-sasl.

Comment 3 Nalin Dahyabhai 2005-12-29 13:35:07 UTC
*** Bug 176660 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.