Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159193 - When creating LVM on RAID partitions the anaconda-ks.cfg is invalid
Summary: When creating LVM on RAID partitions the anaconda-ks.cfg is invalid
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda
Version: 4.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-31 13:13 UTC by Tom Diehl
Modified: 2008-06-21 20:07 UTC (History)
0 users

Fixed In Version: RHEL4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-21 20:07:23 UTC


Attachments (Terms of Use)

Description Tom Diehl 2005-05-31 13:13:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040808 Firefox/0.9.3

Description of problem:
Description of problem: When creating LVM on RAID partitions the
anaconda-ks.cfg is invalid.  In particular, the "raid pv.20 --fstype
physical volume (LVM) --level=RAID1 raid.17 raid.18" line that was
created should have had the fstype quoted since it contains embedded
spaces.




Version-Release number of selected component (if applicable):
anaconda-10.1.1.13-1

How reproducible:
Always

Steps to Reproduce:
1. Do an install of el4 with lvm on raid.
2. reinstall using the partition information from anaconda-ks.cfg
3. Install fails with "Tried to use an undefined partition in RAID specification"
  

Actual Results:  Backtrace occurred.

Expected Results:  Normal install

Additional info:

The following line was generated by anaconda:
raid pv.26 --fstype physical volume (LVM) --level=RAID1 raid.24 raid.25

The above is the problem. Removing the --fstype part fixes the problem.
I suppose putting quotes around "physical volume (LVM)" would also fix it but I have not tested this.

This is the same bug as 119243 which was supposed to be fixed in el3-u3.

Comment 1 Jeremy Katz 2005-06-07 19:31:00 UTC
Fixed in CVS on all branches.


Note You need to log in before you can comment on or make changes to this bug.