Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159184 - excessive ext3_inode_cache slab usage
Summary: excessive ext3_inode_cache slab usage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-31 05:35 UTC by Damian Menscher
Modified: 2015-01-04 22:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-29 08:16:44 UTC


Attachments (Terms of Use)

Description Damian Menscher 2005-05-31 05:35:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050514 Fedora/1.0.4-0.fdr.1.2 Firefox/1.0.4

Description of problem:
An excessive amount of memory is being allocated to the slab for the ext3_inode_cache.  On a machine with 8GB ram and no applications running, free reports 4.5GB of ram in use:

# free
             total       used       free     shared    buffers     cached
Mem:       8079404    6034904    2044500          0     853652     649828
-/+ buffers/cache:    4531424    3547980
Swap:      2096472          0    2096472

The interesting part is from slabtop, though:

 Active / Total Objects (% used)    : 7502225 / 7509918 (99.9%)
 Active / Total Slabs (% used)      : 1120402 / 1120404 (100.0%)
 Active / Total Caches (% used)     : 93 / 131 (71.0%)
 Active / Total Size (% used)       : -305009.98K / -304212.66K (100.3%)
 Minimum / Average / Maximum Object : 0.02K / -0.04K / 128.00K

  OBJS ACTIVE  USE OBJ SIZE  SLABS OBJ/SLAB CACHE SIZE NAME                   
3554924 3554923  99%    0.84K 888731        4   3554924K ext3_inode_cache
3585946 3585941  99%    0.23K 210938       17    843752K dentry_cache

Note that it shows 3.5G of ram being used for the ext3_inode_cache.

I believe the memory got used when backups ran (a process that would walk the filesystem tree).  But it hasn't gone down since then (24 hours).  This might be related to Bug 150945, but there people were complaining about a couple hundred meg of slab usage, whereas here it's 3.5G.

Marking as "high" severity since 3.5G memory disappearing constitutes a "severe memory leak" IMHO.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.27_FC3

How reproducible:
Didn't try

Steps to Reproduce:
1. run a process that walks a large directory tree like du or updatedb

Additional info:

Comment 1 Dave Jones 2005-06-01 05:39:18 UTC
Does this memory get reclaimed if you run something that needs lots of memory ?
This could be perfectly normal, unless it doesn't get reclaimed.


Comment 2 Dave Jones 2005-07-15 18:26:45 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.


Note You need to log in before you can comment on or make changes to this bug.