Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159182 - kickstart install using existing raid devices fails after formatting root filesystem
Summary: kickstart install using existing raid devices fails after formatting root fil...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-31 05:18 UTC by Alexandre Oliva
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-15 15:42:41 UTC


Attachments (Terms of Use)
Patch that, placed in an update disk, worked around the bug, enabling the install to proceed (deleted)
2005-05-31 05:18 UTC, Alexandre Oliva
no flags Details | Diff

Description Alexandre Oliva 2005-05-31 05:18:48 UTC
Description of problem:
After formatting the root filesystem, mdadmLine calls lookup_raid_device, but that fails because existing raid devices aren't registered.

Version-Release number of selected component (if applicable):
FC4-re0530.1

How reproducible:
Every time

Steps to Reproduce:
1.Have an already-installed box with existing raid devices, used as physical volumes or direct filesystems
2.Try to run a kickstart install creating say a new logical volume for the root device
  
Actual results:
Anaconda backtraces after formatting the root filesystem, while generating mdadm.conf

Expected results:
This worked before

Additional info:

Comment 1 Alexandre Oliva 2005-05-31 05:18:48 UTC
Created attachment 114982 [details]
Patch that, placed in an update disk, worked around the bug, enabling the install to proceed

Comment 2 Chris Lumens 2005-05-31 21:01:05 UTC
Applied for FC4 and Rawhide.


Note You need to log in before you can comment on or make changes to this bug.