Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159161 - yum hangs on kernel update
Summary: yum hangs on kernel update
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 3
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-30 20:54 UTC by james
Modified: 2014-01-21 22:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-30 22:19:42 UTC


Attachments (Terms of Use)

Description james 2005-05-30 20:54:30 UTC
From Bugzilla Helper:
User-Agent: Opera/8.0 (X11; Linux i686; U; en)

Description of problem:
Attempting to update the kernel, yum hangs after "Running Transaction Test", with no disc activity and no cpu 
usage.

 $ sudo yum -y update kernel
 ...
 Resolving Dependencies
 --> Populating transaction set with selected packages. Please wait.
 ---> Package kernel.i586 0:2.6.11-1.27_FC3 set to be installed
 --> Running transaction check

 Dependencies Resolved
 Transaction Listing:
   Install: kernel.i586 0:2.6.11-1.27_FC3 - updates-released
 Total download size: 18 M
 Downloading Packages:
 Running Transaction Test
and hangs...

Also tried:
 $ sudo yum -y install kernel
with the same result.


Version-Release number of selected component (if applicable):
yum-2.2.1-0.fc3

How reproducible:
Always

Steps to Reproduce:
1.$ sudo yum -y update kernel
2.
3.
  

Actual Results:  yum hangs with no activity

Expected Results:  install kernel

Additional info:

Comment 1 Seth Vidal 2005-05-30 21:02:38 UTC
does the command 'df' hang?

how many kernels do you have installed?

If you strace the yum command what does it say it is doing?


Comment 2 james 2005-05-30 21:06:41 UTC
Hmm.  I just tried to run
 sudo rpm -ivh /var/cache/yum/updates-released/packages/kernel-2.6.11-1.27_FC3.i586.rpm
and that also hangs with no activity.  This is with rpm-4.3.2-21.

I suppose this is an rpm problem then, and not a yum problem.

Comment 3 Seth Vidal 2005-05-30 21:15:47 UTC
Answer the other questions I mentioned and we can see what might be causing it.

I think knowing what the strace output is and how many kernels you have
installed would help.

out of curiosity - is this really an i586 machine?


Comment 4 james 2005-05-30 21:28:46 UTC
> does the command 'df' hang?

Yes sir'ee Bob!  This seems to have something to do with an NFS mounted directory - flaky NFS at that.
I managed to unmount the remote directory and then rpm - and df - ran without problems.

Athlon machine, K7 I suppose - family 6, stepping 2.

Comment 5 Seth Vidal 2005-05-30 22:19:42 UTC
this is not a bug, closing.




Note You need to log in before you can comment on or make changes to this bug.