Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159160 - Can't access users home directories
Summary: Can't access users home directories
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-30 20:51 UTC by David Bentley
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-06 13:50:06 UTC


Attachments (Terms of Use)
log extract as requested (deleted)
2005-06-02 18:59 UTC, David Bentley
no flags Details

Description David Bentley 2005-05-30 20:51:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When running selinux policy targeted with Allow Samba to share users directories and Allow users to login with CIFS home diesctoris checked I am now unable to acces a users home directory without now disabling protection for the smbd and nmbd demons.

This did work OK at one point after being fixed erlier in the development cycle but I can't find what bug it was reported under.

But it needs to be fixed again before FC4 release if possible.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.23.16-6

How reproducible:
Always

Steps to Reproduce:
see discription

Actual Results:  Shares are visible but you are unable to acces them.

Expected Results:  Able to acces the share and its contents.

Additional info:

Comment 1 David Bentley 2005-05-30 21:59:58 UTC
Thinking now I am not shure if this did ever work because I think that I am
confusing it with another bug that I reported (157873) where you were unable to 
FTP into users home directories and it was this one that was fixed earlier in
the release cycle.

Comment 2 David Bentley 2005-06-01 11:55:09 UTC
Modified to FC4test3 to bring it to someones attention but the 
selinux-policy-targeted-1.23.16-6 is the current latest from development 



Comment 3 Daniel Walsh 2005-06-02 11:59:39 UTC
Are you seeing any AVC messages in your log files?

Dan

Comment 4 David Bentley 2005-06-02 15:23:40 UTC
I will have a further look to see if there are any before I update the system
with todays fixes and report back on what the state of play is both before and
after the update.

I am at work now but will have done the above by about 20:00 BST (19:00 GMT)


Comment 5 David Bentley 2005-06-02 18:59:01 UTC
Created attachment 115103 [details]
log extract as requested

Having had a look at the logs I remembered that I had labeled the users home
directory with "chcon -R -t ftpd_anon_t /home/bentledr" when trying to get ftp
access to the users home directory which was fixed a while ago as a result of a

previous bug report.

So I forced a re-label on next reboot and all is now OK

I assume chcon could have been used to remove the label but the above method
was used in my haste to fix things.

So this is not a bug please feel free to close it.

Comment 6 Daniel Walsh 2005-06-06 13:49:40 UTC
You can use restorecon to fix the labels on a homedir.

restorecon -R -v /home/bentledr would work faster than  a full relable.

Dan 


Note You need to log in before you can comment on or make changes to this bug.