Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159153 - Unable to use spadmin to redefine a CUPS printer as a fax device
Summary: Unable to use spadmin to redefine a CUPS printer as a fax device
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL: http://qa.openoffice.org/issues/show_...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-30 18:46 UTC by Brian Johnson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.9.104-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-14 09:54:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 49980 None None None Never

Description Brian Johnson 2005-05-30 18:46:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.21

Description of problem:
The url to the issue report in the openoffice project explains it all

They say it is a problem created by Fedora


Version-Release number of selected component (if applicable):
openoffice.org-1.1.3-11.5.0.fc3

How reproducible:
Always

Steps to Reproduce:
1. open spadmin
2. redefine a CUPS printer as a oo.org fax device and add a command
3. exit and restart spadmin, the command is gone
  

Actual Results:  No command saved

Expected Results:  Command should have been saved

Additional info:

Comment 1 Brian Johnson 2005-06-10 15:54:41 UTC
why was this closed?

Comment 2 Brian Johnson 2005-06-20 13:58:21 UTC
No idea why this was closed.

Also, I've upgraded to FC4 and problem has changed but results are the same.

Now you cannot redefine a CUPS printer as a fax device at all.

Just to clarify, when using fax4cups it would be best if openoffice.org would
auto sense that printer as a fax device, but short of that it would be best to
be able to use spadmin to redefine it on each workstation.

Current situation is that fax2cups device shows in oo.org but is unusable.  A
second fax device must be added to use the fax4cups system which results in 2
printers showing up in oo.org.  One works, the other doesn't.  

Confusing, and it seems to be interpreted as an obvious bug, for users.



Comment 3 Brian Johnson 2005-06-22 13:29:08 UTC
Fax4cups homepage:
http://vigna.dsi.unimi.it/fax4CUPS

It is really easy to install and easily expands faxmodem sharing through your
network by using the CUPS autobrowsing features.

I reported it on openoffice.org here:
http://qa.openoffice.org/issues/show_bug.cgi?id=49920

They closed it because 1.1.x worked differently than 1.1.3 in FC3.  In their
version, the CUPS printers did not list in the spadmin program at all so
defining a CUPS printer as a fax device was possible by simply defining a oo.org
printer with the same name as a CUPS printer.  

Their solution was still not fully acceptable since although CUPS printers
displayed in the oo.org printer selection boxes (but not in spadmin), they did
not list the CUPS printer classes (groups of printers definable in CUPS) at all. 


I had to approach the problem from another angle to get them to consider doing
anything, so the above bug report evolved into this feature enhancement request
to Autosense fax4cups devices and configure automatically
http://qa.openoffice.org/issues/show_bug.cgi?id=49980

This bug report is related to this issue since it reinforces the current need to
use spadmin for setting up fax devices to "swallow" the fax number (ie not
include the fax number field in the fax output)
http://qa.openoffice.org/issues/show_bug.cgi?id=49981



Note You need to log in before you can comment on or make changes to this bug.