Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159150 - glibc detected *** malloc(): memory corruption: 0x09c59060
Summary: glibc detected *** malloc(): memory corruption: 0x09c59060
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dos2unix
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-30 18:31 UTC by Timo Lindfors
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-09 14:02:40 UTC


Attachments (Terms of Use)

Description Timo Lindfors 2005-05-30 18:31:36 UTC
Description of problem:
dos2unix crashes with some specific command line parameters.

Version-Release number of selected component (if applicable):
dos2unix 3.1 (Thu Nov 19 1998)
linux 2.6.11-1.14_FC3

How reproducible:
Always

Steps to Reproduce:
1. mkdir -p video/video/natural/microsoft-2.3-001213/sys/decoder/ mpeg4ip-1.2/common/video/mpeg4-2000/sys/decoder/
2. touch video/video/natural/microsoft-2.3-001213/sys/decoder/mbinterlacedec.cpp mpeg4ip-1.2/common/video/mpeg4-2000/sys/decoder/mbinterlacedec.cpp
3. dos2unix video/video/natural/microsoft-2.3-001213/sys/decoder/mbinterlacedec.cpp mpeg4ip-1.2/common/video/mpeg4-2000/sys/decoder/mbinterlacedec.cpp
  
Actual results:
dos2unix: converting file video/video/natural/microsoft-2.3-001213/sys/decoder/mbinterlacedec.cpp to UNIX format ...
dos2unix: converting file mpeg4ip-1.2/common/video/mpeg4-2000/sys/decoder/mbinterlacedec.cpp to UNIX format ...
*** glibc detected *** malloc(): memory corruption: 0x09f17060 ***
Aborted (core dumped)


Expected results:
dos2unix should recrate the files (they are empty so there isn't much to convert) and not crash.


Additional info:
This bug seems to be very sensitive to the length of the filenames that are given as command line arguments.

Comment 1 Sitsofe Wheeler 2005-05-30 18:47:43 UTC
Sounds like a dup of bug #150277

Comment 2 Tim Waugh 2005-05-31 12:02:50 UTC
Perhaps time for an update.

Comment 3 Tim Waugh 2005-05-31 14:58:42 UTC
Please try this update:

https://www.redhat.com/archives/fedora-test-list/2005-May/msg01590.html

Comment 4 Max Kanat-Alexander 2005-06-29 03:25:08 UTC
I get something similar on RHEL 4, when trying to rebuild an old Red Hat
perl-5.8.0 SRPM (so that I can have multiple perls on a development testing
machine):

dos2unix: converting file jpl/JNI/JNI.xs to UNIX format ...
*** glibc detected *** free(): invalid pointer: 0x08792038 ***
/var/tmp/rpm-tmp.99171: line 74: 24303 Aborted

I can re-arrange the dos2unix calls in the perl.spec file, and then I get:

dos2unix: problems renaming 'jpl/JNI/d2utmpvSaZCV' to 'jpl/JNI/JNI.xs'
          output file remains in 'jpl/JNI/d2utmpvSaZCV'

Comment 5 Max Kanat-Alexander 2005-06-29 03:25:55 UTC
Oh, and FWIW, I have dos2unix-3.1-21.

Comment 6 Max Kanat-Alexander 2005-06-29 03:31:16 UTC
OK, I can confirm that at least my problem is fixed by dos2unix-3.1-24.

Comment 7 Tim Waugh 2005-06-29 08:16:13 UTC
Will someone try the test update for Fedora Core 3 mentioned in comment #3? 
Otherwise there is no point in releasing it as a final update.


Note You need to log in before you can comment on or make changes to this bug.