Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159132 - ntpd fails to shutdown
Summary: ntpd fails to shutdown
Keywords:
Status: CLOSED DUPLICATE of bug 154759
Alias: None
Product: Fedora
Classification: Fedora
Component: ntp
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jiri Ryska
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-30 14:09 UTC by Jonathan Underwood
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-30 14:52:29 UTC


Attachments (Terms of Use)

Description Jonathan Underwood 2005-05-30 14:09:15 UTC
Description of problem:
ntpd fails to stop cleanly.

Version-Release number of selected component (if applicable):
ntp-4.2.0.a.20040617-4

How reproducible:
every time

Steps to Reproduce:
1. /sbin/service ntpd stop (or shut system down)
2. 
3.
  
Actual results:
Shutting down ntpd:                                        [FAILED]

Expected results:
Shutdown should succeed

Additional info:

Comment 1 Jiri Ryska 2005-05-30 14:17:21 UTC
Is ntpd running? And if not, what kernel you have?
/sbin/service ntpd status
uname -r

Comment 2 Jonathan Underwood 2005-05-30 14:45:04 UTC
Oddly, this isn't reproducible every time. For example, check the following
session below. "ntpd dead but subsys locked" must be a big clue. Have seen these
issues with kernels 2.6.11-1.27_FC3smp and 2.6.11-1.14_FC3smp.

[root@pasiphae jgu]# /sbin/service ntpd status
ntpd (pid 3773) is running...
[root@pasiphae jgu]# /sbin/service ntpd stop
Shutting down ntpd:                                        [  OK  ]
[root@pasiphae jgu]# /sbin/service ntpd start
ntpd: Synchronizing with time server:                      [  OK  ]
Starting ntpd:                                             [  OK  ]
[root@pasiphae jgu]# /sbin/service ntpd stop
Shutting down ntpd:                                        [FAILED]
[root@pasiphae jgu]# uname -r
2.6.11-1.27_FC3smp
[root@pasiphae jgu]# /sbin/service ntpd start
ntpd: Synchronizing with time server:                      [  OK  ]
Starting ntpd:                                             [  OK  ]
[root@pasiphae jgu]# /sbin/service ntpd stop
Shutting down ntpd:                                        [  OK  ]
[root@pasiphae jgu]# /sbin/service ntpd start
ntpd: Synchronizing with time server:                      [  OK  ]
Starting ntpd:                                             [  OK  ]
[root@pasiphae jgu]# /sbin/service ntpd stop
Shutting down ntpd:                                        [FAILED]
[root@pasiphae jgu]# /sbin/service ntpd stop
Shutting down ntpd:                                        [FAILED]
[root@pasiphae jgu]# /sbin/service ntpd status
ntpd dead but subsys locked

Comment 3 Jiri Ryska 2005-05-30 14:52:29 UTC
It should be duplicate of #154759. You can try this workaround:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=145258#c13
For now I mark this as duplicate. If you disagree with duplicity
please reopen it again.

*** This bug has been marked as a duplicate of 154759 ***


Note You need to log in before you can comment on or make changes to this bug.