Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159128 - monitor probe succeeds on i386, fails on x86_64
Summary: monitor probe succeeds on i386, fails on x86_64
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-30 11:42 UTC by Dan Hollis
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-31 03:11:13 UTC


Attachments (Terms of Use)

Description Dan Hollis 2005-05-30 11:42:37 UTC
Description of problem:
FC4T3 i386 correctly probes monitor. FC4T3 x86_64 on exact same machine fails.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run i386 installer. Probing for monitor type: PHILIPS 107S
2.Run x86_64 installer. Probing for monitor type: Unknown
3.Profit!
  
Actual results:
x86_64 installer is unable to probe monitor. while i386 installer on exact same
machine works fine.

Expected results:
You would expect x86_64 to be able to probe.

Additional info:
Video card - GF4 440mx.
Monitor - Philips 107S

Comment 1 Jeremy Katz 2005-05-31 03:11:13 UTC
This is because the real mode monitor probing we do can only be done on i386 and
not x86_64.  Unfortunately, there's no generic, cross-platform way to do monitor
probing and the methods that do exist are all card-specific.  X has code for
doing this, but doesn't really export it in a way that can be used.  There's
another (old) bug for tracking fixing that at which point we can do something
better.

Comment 2 Dan Hollis 2005-05-31 03:56:17 UTC
what's the bug number for tracking it? might be nice to make 159128 'depends on' it.


Note You need to log in before you can comment on or make changes to this bug.