Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159120 - ACPI module options are not honored
Summary: ACPI module options are not honored
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
: 173189 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-05-30 07:53 UTC by Thomas M Steenholdt
Modified: 2014-03-17 02:54 UTC (History)
2 users (show)

Fixed In Version: 8.12-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-30 19:59:19 UTC


Attachments (Terms of Use)
proposed patch - moving from insmod to modprobe (deleted)
2005-05-30 07:57 UTC, Thomas M Steenholdt
no flags Details | Diff

Description Thomas M Steenholdt 2005-05-30 07:53:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
rc.sysinit uses insmod to load acpi specific modules, thus bypassing any option that might be specified in modprobe.conf.

Version-Release number of selected component (if applicable):
initscripts-8.11.1-1

How reproducible:
Always

Steps to Reproduce:
1. configure an acpi module with a verifiable option in modprobe.conf
2. reboot and verify that the option was not passed on module loading
3.
  

Actual Results:  ACPI module parameters are not honored

Expected Results:  ACPI module parameters should be honored

Additional info:

Comment 1 Thomas M Steenholdt 2005-05-30 07:57:32 UTC
Created attachment 114962 [details]
proposed patch - moving from insmod to modprobe

Comment 2 Bill Nottingham 2005-05-30 19:59:19 UTC
Added, will be in 8.12-1.

Comment 3 Bill Nottingham 2005-11-16 20:06:57 UTC
*** Bug 173189 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.