Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159088 - selinux deny when pushing the power button
Summary: selinux deny when pushing the power button
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-29 06:56 UTC by Florin Andrei
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-29 11:03:48 UTC


Attachments (Terms of Use)

Description Florin Andrei 2005-05-29 06:56:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
FC4t3 system, kept up to date via yum.
When pushing the power button, the system shuts down gracefully, but there's also this selinux message in the logs:

May 28 23:49:15 demo shutdown: shutting down for system halt
May 28 23:49:15 demo kernel: audit(1117349355.101:5): avc:  denied  { read } for  pid=2037 comm="init" name=config dev=hda2 ino=65989 scontext=system_u:system_r:apmd_t tcontext=system_u:object_r:selinux_config_t tclass=file
May 28 23:49:15 demo init: Switching to runlevel: 0

selinux is set to "permissive"

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.23.16-6

How reproducible:
Always

Steps to Reproduce:
1.see above
2.
3.
  

Additional info:

Comment 1 Daniel Walsh 2005-05-29 11:03:48 UTC
Please only submit bugs on policy that happen in enforcing mode.  THis message
would not happen there since a previous dontaudit would have prevented the
application from getting this far.

The way this works is the app tries to read a directory,  SELinux says no and
the app moves on.  SELinux policy tells the kernel to not audit the directory
search.  

In permissive mode, the same thing happens except this time the app is allowed
to continue,  everything that it does in the directory is then audited.  

So please run in enforcing mode.


Note You need to log in before you can comment on or make changes to this bug.