Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159060 - ntpd can segfault on start
Summary: ntpd can segfault on start
Keywords:
Status: CLOSED DUPLICATE of bug 154759
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jiri Ryska
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-28 12:27 UTC by Nigel Horne
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-30 12:15:23 UTC


Attachments (Terms of Use)
ntpd configuration file (deleted)
2005-05-28 12:29 UTC, Nigel Horne
no flags Details

Description Nigel Horne 2005-05-28 12:27:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.7.8-1.3.1

Description of problem:
With the attached ntp.conf, ntpd will segfault about 75% of the time when starting

Version-Release number of selected component (if applicable):
ntp-4.2.0.a.20040617-4

How reproducible:
Sometimes

Steps to Reproduce:
1. /usr/sbin/ntpd -u ntp:ntp -D12 -n  -p /var/run/ntpd.pid
2.
3.
  

Actual Results:  Debug1: 12 -> c = 12
ntpd 4.2.0a@1.1190-r Mon Oct 11 09:10:20 EDT 2004 (1)
Debug1: 12 -> c = 12
addto_syslog: ntpd 4.2.0a@1.1190-r Mon Oct 11 09:10:20 EDT 2004 (1)
adding new filegen
adding new filegen
adding new filegen
adding new filegen
adding new filegen
adding new filegen
addto_syslog: set_process_priority: Leave priority alone: priority_done is <2>
addto_syslog: precision = 2.000 usec
create_sockets(123)
addto_syslog: no IPv6 interfaces found
address_okay: listen Virtual: 1, IF name: lo, Up Flag: 1
address_okay: listen Virtual: 1, IF name: eth0, Up Flag: 1
address_okay: listen Virtual: 1, IF name: eth1, Up Flag: 1
bind() fd 4, family 2, port 123, addr 0.0.0.0, flags=8
flags for fd 4: 04002
addto_syslog: Listening on interface wildcard, 0.0.0.0#123
bind() fd 5, family 2, port 123, addr 127.0.0.1, flags=0
flags for fd 5: 04002
addto_syslog: Listening on interface lo, 127.0.0.1#123
bind() fd 6, family 2, port 123, addr 192.168.1.1, flags=8
flags for fd 6: 04002
addto_syslog: Listening on interface eth0, 192.168.1.1#123
bind() fd 7, family 2, port 123, addr 192.168.1.253, flags=8
flags for fd 7: 04002
addto_syslog: Listening on interface eth1, 192.168.1.253#123
create_sockets: ninterfaces=4
interface 0:  fd=4,  bfd=-1,  name=wildcard,  flags=0x8,  scope=0
              sin=0.0.0.0  bcast=0.0.0.0,  mask=255.255.255.255
interface 1:  fd=5,  bfd=-1,  name=lo,  flags=0x5,  scope=0
              sin=127.0.0.1  mask=255.0.0.0
interface 2:  fd=6,  bfd=-1,  name=eth0,  flags=0x9,  scope=0
              sin=192.168.1.1  bcast=192.168.1.155,  mask=255.255.255.128
interface 3:  fd=7,  bfd=-1,  name=eth1,  flags=0x9,  scope=0
              sin=192.168.1.253  bcast=192.168.1.255,  mask=255.255.255.128
init_io: maxactivefd 7
local_clock: time 0 clock 0.000000 offset 0.000000 freq 0.000 state 0
Debug2: 12 -> c = 12
getaddrinfo uk.pool.ntp.org
Segmentation fault

Expected Results:  ntpd should run

Additional info:

Comment 1 Nigel Horne 2005-05-28 12:29:04 UTC
Created attachment 114941 [details]
ntpd configuration file

Comment 2 Jiri Ryska 2005-05-30 12:15:23 UTC
This should be duplicate of #154759, marking duplicate.

*** This bug has been marked as a duplicate of 154759 ***


Note You need to log in before you can comment on or make changes to this bug.