Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159057 - (Dual Xeon) SMP kernel stuck during boot, UP works
Summary: (Dual Xeon) SMP kernel stuck during boot, UP works
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
Depends On:
TreeView+ depends on / blocked
Reported: 2005-05-28 10:39 UTC by Jonathan Deitch
Modified: 2007-11-30 22:11 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-05-29 02:39:00 UTC

Attachments (Terms of Use)

Description Jonathan Deitch 2005-05-28 10:39:08 UTC
+++ This bug was initially created as a clone of Bug #158413 +++

Description of problem:
Dual CPU Opteron with FC4 32bit installed.  Bootup gets stuck at:

EXT3-fs: mounted filesystem with ordered data mode.
Switching to new root
unmounting old /proc
unmounting old /sys
cfq: depth 4 reached, tagging now on

CFQ is not at fault, because elevator=deadline gets stuck there too, without the
CFQ message of course.

This point seems to be after initrd's "init" script, where it seems to load
SELinux.  Booting the UP kernel gets past this point with these kind of messages:

security:  3 users, 6 roles, 760 types, 87 bools
security:  55 classes, 170468 rules
SELinux:  Completing initialization.

Disabling selinux in /etc/sysconfig/selinux or booting with maxcpus=1 makes no

Version-Release number of selected component (if applicable):
WORKING kernel-2.6.11-1.1253_FC4smp
WORKING kernel-2.6.11-1.1267_FC4smp
WORKING kernel-2.6.11-1.1268_FC4smp
  (broke somewhere here, no builds available in between)
BROKEN  kernel-2.6.11-1.1275_FC4smp
BROKEN  kernel-2.6.11-1.1276_FC4smp
BROKEN  kernel-2.6.11-1.1286_FC4smp
BROKEN  kernel-2.6.11-1.1323_FC4smp
BROKEN  kernel-2.6.11-1.1337_FC4smp

Tyan motherboard
2x1.4GHz Opteron
Adaptec I2O with i2o_block driver
Bug #158410 mentions similar behavior with a SATA controller on dual Opteron.

Comment 1 Jonathan Deitch 2005-05-28 10:40:59 UTC
Running into a similar problem, on an Intel dual-xeon server board.

System will boot smp clear through to the login prompt, no errors.

But as SOON as the kernel inits at the start of the boot process, *all IO locks
up*.  No keyboard, no mouse, no network, nothing.

So once the system has finished booting, it's completely unusable : it sits
there blinking a cursor, and is totally inaccesible via keyboard, mouse, or network.

This happens regardless of runlevel.

Verified on a stock FC4T3 install, with all yum updates installed, and on every
2.6.11 FC4 smp kernel available right up to the new 1363 one.

System was installed as "server", with all defaults left checked.

Logs not only show no errors, but do not log the fact that the system booted
smp, period.  It's like syslog never even ran.

More details will be provided if someone needs them ...

- Jonathan

Comment 2 Warren Togami 2005-05-29 00:17:13 UTC
This is unlikely to be the same vdso issue, because it was fixed.  UP kernel
boots but SMP kernel doesn't?  Your report is confusing.

Comment 3 Warren Togami 2005-05-29 00:22:29 UTC
Does kernel-2.6.11-1.1268_FC4smp boot on that machine while subsequent kernels
do not?

Comment 4 Jonathan Deitch 2005-05-29 01:29:10 UTC
no ... 1268 (and any other FC4 smp kernel) fail to boot

Board is a Intel SE7501CW2, with two 1.8ghz Xeons, 512mb memory.

There are NO io cards installed, and the system is stock off the FC4T3 isos.

It boots clear through to the login prompt (whatever runlevel you select) and is
then frozen.  If, for instance, you try and move the mouse during the X init, or
hit capslock, you notice that from the instant Anaconda inits, all IO is dead.

I've tried running all yum updates; no help ... I've tried every FC4 smp kernel
from FC4_1267 to the current 1363, all have the same exact result.

It makes no difference if I'm running the stock install off the ISOs, or have
run yum update to bring to current.

All of the above kernels boot perfectly in *non* smp.  It's just smp kernels --
any smp --that flat-out fail.

Knoppix 3.82 (running a 2.6.11 kernel) boots flawleslly.

- Jonathan

Comment 5 Warren Togami 2005-05-29 02:39:00 UTC
Then you shouldn't have cloned that bug.  There is absolutely no similarity
between the original report and this.  For clarity please report all those
details in a new report.

Note You need to log in before you can comment on or make changes to this bug.