Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159047 - anaconda has parted error where partition's data region doesn't occupy the entire partition
Summary: anaconda has parted error where partition's data region doesn't occupy the en...
Alias: None
Product: Fedora
Classification: Fedora
Component: parted
Version: rawhide
Hardware: powerpc
OS: Linux
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Brock Organ
: 163263 165883 185637 (view as bug list)
Depends On:
Blocks: FC4Update
TreeView+ depends on / blocked
Reported: 2005-05-28 02:32 UTC by Colin Charles
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version: 1.6.22-3.FC4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-06-16 15:11:24 UTC

Attachments (Terms of Use)

Description Colin Charles 2005-05-28 02:32:22 UTC
Description of problem: This is anaconda calling parted, so please feel free to
reassign to parted (clumens). From rawhide 20050526, burn the boot.iso, pop it
into the iBook 2.2 G3 800MHz that currently is:

15GB - Mac OS X 10.4 (tiger)
15GB - unpartitioned space (as performed by the apple installer)

Parted gives me an error the moment the X11 anaconda interface starts up (i.e.
after I give it NFS details).

parted exception: Error: The partition's data region doesn't occupy the entire

I'm given the option to Ignore/Cancel. Clicking ignore twice, gives me:

parted exception: Error: Attemp to read sectors 16-18 outside of partition on

And I can't partition, etc... Installer seems borked.

Version-Release number of selected component (if applicable):

How reproducible:

I'm thinking the 20050527 tree is pointless to try, because anaconda didn't get

I also tried booting with: "linux maxcpus=1 noisapnp", and it made no difference
(the kernel already had CONFIG_ISAPNP disabled in
kernel-2.6.11-1.1353_FC4.ppc.rpm anyways)

Priority high, because we seem to be wanting to make a release or something soon...

Comment 1 Colin Charles 2005-05-28 02:32:55 UTC
oops, powerpc.

Comment 2 Colin Charles 2005-05-28 02:42:08 UTC
This is actually similar to bug #158029 as well. And I tried what clumens
suggested (parted /dev/hda print) and I get the same error message with the
Ignore/Cancel option on the CLI at tty2

Comment 3 Paul Nasrat 2005-05-29 15:31:53 UTC
Does your free space volume have a name?  can you choose ignore and paste in
what parted says from print.  Did you use OS X diskutil to create the partitions?

You can grab pdisk from and check.

Chris and I looked at this and it's an issue with parted expecting free space to
be labled Extra (IIRC).

Comment 4 Colin Charles 2005-05-30 06:08:16 UTC
Free space volume has no name. I did choose ignore, and broke out to a shell,
and I got the ignore/error messages from the usual "parted /dev/hda print". Yes,
I used OS X diskutil to create the partition (this time I choose to not format
the 2nd partition as HFS+ but leave it as free space). 

Will have to try pdisk next, seeing that I don't have Linux installed (yet
another clean format issue. *groan*)

Comment 5 Colin Charles 2005-05-31 16:40:01 UTC
Okay, in console, after typing Ignore twice, I got parted to give me a print out

Disk geometry for /dev/hda: 0.000-28615.781 megabytes
Disk label type: mac
Minor	Start	End	Filesystem	Name		Flags
1	0.000	0.031			Apple
2	0.031	0.058			Macintosh
3 	0.059	0.085			Macintosh
4	0.086	0.113			Macintosh
5	0.113	0.140			Macintosh
6	0.141	0.390			Macintosh
7	0.391	0.640			Macintosh
8	0.641	0.890			Patch Partition
9	0.891	128.890	hfs
10	128.891	14308.781	hfs+	Apple_HFS_Untitled_2
11	14308.781 28615.773
12	28615.773 28615.781

Comment 6 Colin Charles 2005-05-31 16:48:51 UTC
and pdisk -l /dev/hda

Partition map (with 512 byte blocks) on '/dev/hda'
 #:                type name                   length   base     ( size )
 1: Apple_partition_map Apple                      63 @ 1       
 2:      Apple_Driver43*Macintosh                  56 @ 64      
 3:      Apple_Driver43*Macintosh                  56 @ 120     
 4:    Apple_Driver_ATA*Macintosh                  56 @ 176     
 5:    Apple_Driver_ATA*Macintosh                  56 @ 232     
 6:      Apple_FWDriver Macintosh                 512 @ 288     
 7:  Apple_Driver_IOKit Macintosh                 512 @ 800     
 8:       Apple_Patches Patch Partition           512 @ 1312    
 9:          Apple_Free                        262144 @ 1824     (128.0M)
10:           Apple_HFS "Hermione"           29040416 @ 263968   ( 13.8G)
11:          Apple_Free                      29300720 @ 29304384 ( 14.0G)
12:          Apple_Free                            16 @ 58605104

Device block size=512, Number of Blocks=58605120 (27.9G)
DeviceType=0x0, DeviceId=0x0
1:  23 @ 64, type=0x1
2:  36 @ 120, type=0xffff
3:  21 @ 176, type=0x701
4:  34 @ 232, type=0xf8ff

Comment 7 Chris Lumens 2005-06-01 15:23:13 UTC
It looks like you are doing an NFS install.  If so, are you able to add files to
the tree you're installing from?  If you can do that, I've got a test libparted
you can try out before we send the fix back upstream.  The procedure is:

(1) Make the directory RHupdates in the top level of the distribution tree (at
the same level as the README and everything, in other words).
(2) Download the contents of and
add them to the RHupdates directory.
(3) Also make the symlinks and pointing to that
file as well.
(4) Boot up the machine you're installing, use the NFS method, and see if it works.

Comment 8 Colin Charles 2005-06-02 10:16:24 UTC
Hmm, dunno if Paul told you over the cubicles, but this did work, fwiw. I now
have a iBook that runs Fedora again, with a working parted. Thanks Chris.

Comment 9 Chris Lumens 2005-06-02 14:24:09 UTC
Glad to hear it.  I sent the patch upstream and if it's accepted, I'll be
releasing a parted update for FC4.

Comment 10 Frank Heldt 2005-06-15 13:16:13 UTC
I wanted to install final FC4-ppc (from CD) on my old PowerPC G4 today and hit 
the same problem. What can you do, if the only option is CD installation? At 
the moment FC4 final is not installable.

Comment 11 Chris Lumens 2005-06-15 14:27:43 UTC
Make sure your Apple_Free partitions have a name of "Extra".  This should allow
you to work around the problem and successfully install.

Comment 12 Paul Nasrat 2005-06-15 15:44:27 UTC
From fedora-ppc list but here so people can find it too

you can boot installer to first screen - switch to tty2

cd /tmp
chmod 755 pdisk
./pdisk <disk>
n (Change name)
(freespace partition no)

Comment 13 Chris Lumens 2005-06-16 15:11:24 UTC
Pushed in update FEDORA-2005-420.

Comment 14 Jeff Francis 2005-06-23 19:46:18 UTC
Can you even wget at this point? I.e., is there network connectivity?

(In reply to comment #12)
> From fedora-ppc list but here so people can find it too
> you can boot installer to first screen - switch to tty2
> cd /tmp
> wget
> chmod 755 pdisk
> ./pdisk <disk>
> n (Change name)
> (freespace partition no)
> Extra
> w
> q

Comment 15 Jeff Francis 2005-06-23 21:22:09 UTC
Here was my workaround for installing Fedora 4 on a Mac Mini with dual boot 
Mac OS X

- Boot from Mac OS X Install DVD and go into the Disk Utility to create the 
- Created two equially sized partitions: 1 - Mac, 2 - Free space
- Proceeded to install OS X on the Mac partition
- Once all the OS X stuff was done, rebooted to Fedora 4 PPC DVD
- When the anaconda installer GUI comes up do a Ctrl+Opt+F2 to get to a shell
- Ran parted and did a "print" command (when you do this you'll get the 
formentioned errors). Ignore them and parted continues.
- Find the Free Space partitions (there are actually two partitions listed per 
partitions created with the Mac Disk Utility - a big one and a little one per 
partition - on my Mac Mini the two free partitions were #4 and #5)
- In parted do a "name" it will prompt for partition number enter 4 and then 
enter the name "Extra" and the name prompt
- Repeat for the  partition #5 (again see what print shows you and use those 
numbers vs. 4 and 5 which are my specifics)
- If you do a print again you shouldn't see the Free Space partitions.
- Exit parted
- Ctrl+Opt+F7 to get back to the installer GUI
- Proceed as normal. You shouldn't see any errors.

Another suggestion is to edit yaboot.conf and set the default delay=5 to 
something a little higher like delay=30.

Comment 16 Jeremy Katz 2005-08-15 18:46:00 UTC
*** Bug 165883 has been marked as a duplicate of this bug. ***

Comment 17 Rahul Sundaram 2005-09-05 05:31:04 UTC
*** Bug 163263 has been marked as a duplicate of this bug. ***

Comment 18 David Woodhouse 2005-09-28 11:15:32 UTC
Install images with this fixed can be found at

Comment 19 Paul Nasrat 2006-03-16 18:13:06 UTC
*** Bug 185637 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.