Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159042 - rpm failing after upgrade
Summary: rpm failing after upgrade
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-27 23:31 UTC by Paul F. Johnson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-26 22:36:14 UTC


Attachments (Terms of Use)
Anaconda logfile (deleted)
2005-05-28 12:01 UTC, Paul F. Johnson
no flags Details
Anaconda syslog file (deleted)
2005-05-28 12:01 UTC, Paul F. Johnson
no flags Details
Anaconda xlog file (deleted)
2005-05-28 12:02 UTC, Paul F. Johnson
no flags Details
Upgrade logfile (deleted)
2005-05-28 12:03 UTC, Paul F. Johnson
no flags Details
More anaconda logs (deleted)
2005-06-16 16:13 UTC, Filip Miletic
no flags Details
More anaconda logs (deleted)
2005-06-16 16:14 UTC, Filip Miletic
no flags Details

Description Paul F. Johnson 2005-05-27 23:31:00 UTC
Description of problem:
Upgrading from FC2 to FC4t3 using the standard CDs is causing a major snafu with
rpm post install (including the boot loader not being found - see the additional
comments for packages failed to install)

Version-Release number of selected component (if applicable):
FC4t3 CDs

How reproducible:
Unsure, I've only done this once though it didn't occur when upgrading from FC2
to FC4t2

Steps to Reproduce:
1. Use the FC4t3 CDs to upgrade an FC2 box to FC4t3
2.
3.
  
Actual results:
rpm fails to work giving the following messages

rpmdb : Program version 4.2 does not match environment version
error : db4 error (22) from dbenv->open : Invalid argument
error : cannot open package index using db3 - invalid argument (22)
error : cannot open packages in /var/lib/rpm

I originally tried to clear this by deleting the old __db files in /var/lib/rpm
and /usr/lib/rpmdb/i386-redhat-linux/redhat and doing a rebuild.

Expected results:
The update should have worked

Additional info:
Some of the packages I've noticed which were not installed during the update
includes

kernel
xorg-x11
yum
rpm

There are quite a few others as well.

Comment 1 Paul Nasrat 2005-05-27 23:49:00 UTC
Please attach the upgrade logs individually and uncompressed, so we can
investigate why packages were not upgrade.  /root/upgrade.log /var/log/anaconda*

Comment 2 Paul F. Johnson 2005-05-28 12:01:02 UTC
Created attachment 114937 [details]
Anaconda logfile

Comment 3 Paul F. Johnson 2005-05-28 12:01:41 UTC
Created attachment 114938 [details]
Anaconda syslog file

Comment 4 Paul F. Johnson 2005-05-28 12:02:19 UTC
Created attachment 114939 [details]
Anaconda xlog file

Comment 5 Paul F. Johnson 2005-05-28 12:03:06 UTC
Created attachment 114940 [details]
Upgrade logfile

Comment 6 Paul Nasrat 2005-06-16 15:24:34 UTC
Hmm we have a lot of these type errors:

error: %post(net-tools-1.60-52.i386) scriptlet failed, exit status 255

Were you running SELinux in fc2? 
Is it possible your filesystem labels were out of sync?

Could you try an upgrade with selinux=0 and disabling selinux in anaconda (you
can redo post boot with system-config-securitylevel and reboot so we get the
labels done).

Comment 7 Filip Miletic 2005-06-16 16:00:29 UTC
One more report of a similar problem. Here is the result of

$ grep fail upgrade.log
error: %trigger(redhat-lsb-1.3-4.i386) scriptlet failed, exit status 255
error: %post(libwmf-0.2.8.3-8.i386) scriptlet failed, exit status 1
error: %post(librsvg2-2.9.5-2.i386) scriptlet failed, exit status 1
error: %post(gnome-utils-2.10.0-3.i386) scriptlet failed, exit status 1
error: %pre(screen-4.0.2-9.i386) scriptlet failed, exit status 10
error:   install: %pre scriptlet failed (2), skipping screen-4.0.2-9

For the suspected selinux issues here are /etc/grub.conf and /etc/sysconfig/selinux

$ cat grub.conf
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,2)
#          kernel /boot/vmlinuz-version ro root=/dev/hda3
#          initrd /boot/initrd-version.img
#boot=/dev/hda
timeout=10
splashimage=(hd0,2)/boot/grub/splash.xpm.gz
default=0
title Fedora Core (2.6.11-1.1369_FC4smp)
        root (hd0,2)
        kernel /boot/vmlinuz-2.6.11-1.1369_FC4smp ro root=LABEL=/ rhgb quiet
        initrd /boot/initrd-2.6.11-1.1369_FC4smp.img

---

$ cat config
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#       enforcinfg - SELinux security policy is enforced.
#       permissive - SELinux prints warnings instead of enforcing.
#       disabled - No SELinux policy is loaded.
SELINUX=disabled

# SELINUXTYPE= can take one of these two values:
#       targeted - Only targeted network daemons are protected.
#       strict - Full SELinux protection.
SELINUXTYPE=strict


Comment 8 Filip Miletic 2005-06-16 16:13:09 UTC
Created attachment 115548 [details]
More anaconda logs

Comment 9 Filip Miletic 2005-06-16 16:14:11 UTC
Created attachment 115549 [details]
More anaconda logs

Comment 10 Paul Nasrat 2005-09-26 22:18:25 UTC
Did FC4 final fix this for you?

Comment 11 Paul F. Johnson 2005-09-26 22:36:14 UTC
Yeah, I'll close it.


Note You need to log in before you can comment on or make changes to this bug.