Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159040 - kde application crash while closing after upgrade from update 4 to update 5
Summary: kde application crash while closing after upgrade from update 4 to update 5
Keywords:
Status: CLOSED DUPLICATE of bug 159039
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kdelibs
Version: 3.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-27 23:17 UTC by Wesly Chen
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-31 18:50:19 UTC


Attachments (Terms of Use)

Description Wesly Chen 2005-05-27 23:17:40 UTC
Description of problem:
The RedHat Desktop 3.0 upgraded from update 4 to update 5, after reboot, all
the KDE applications, i.e. kdesktop_lock, carsh after exit/closing.
The detail message complain about db library /lib/tls/libthread_db.so.1.



Version-Release number of selected component (if applicable):
kdelibs-3.1.3-6.10

How reproducible:


Steps to Reproduce:
1. Login to KDE session
2. Open Kterminal or the screen_lock kick off automatically after a period of 
idle time
3. Close the Kterminal or unlock the screen. Bang!!
  
Actual results:
unknown - The KDE Crash Handler
The application unknown (kdesktop_lock) crashed and caused the signal 11 
(SIGSEGV).

Expected results:
No crash.

Additional info:
Backtrace:
(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 1073842432 (LWP 26164)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x002d988e in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#0  0x002d988e in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#1  0x001ed00d in KCrash::defaultCrashHandler () from /usr/lib/libkdecore.so.4
#2  <signal handler called>
#3  0x0062cbea in glXChannelRectSyncSGIX () from /usr/lib/libGL.so.1
#4  0x08ea00f0 in ?? ()
#5  0x0065e540 in ?? () from /usr/lib/libGL.so.1
#6  0x08ea00f0 in ?? ()
#7  0x0062eed6 in glXChannelRectSyncSGIX () from /usr/lib/libGL.so.1
#8  0x08ea00f0 in ?? ()
#9  0x08ea00f0 in ?? ()
#10 0x00936c84 in ?? () from /usr/X11R6/lib/libX11.so.6
#11 0x08ea5990 in ?? ()
#12 0x0086d422 in XCloseDisplay () from /usr/X11R6/lib/libX11.so.6
#13 0x010d250b in qt_cleanup () from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#14 0x0112d5b4 in QApplication::~QApplication$base ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#15 0x001840ca in KApplication::~KApplication () from /usr/lib/libkdecore.so.4
#16 0x08053847 in ?? ()
#17 0xbfff9b90 in ?? ()
#18 0x080546fd in _IO_stdin_used ()
#19 0x00000001 in ?? ()
#20 0x00000000 in ?? ()

Comment 1 Suzanne Hillman 2005-05-31 18:50:19 UTC

*** This bug has been marked as a duplicate of 159039 ***


Note You need to log in before you can comment on or make changes to this bug.