Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159035 - '.' not allowed in usernames when creating new account
Summary: '.' not allowed in usernames when creating new account
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-users
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard: RHEL4U3NAK
: 172106 204292 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-27 22:21 UTC by David Lehman
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version: RHBA-2007-0071
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-08 19:21:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0071 normal SHIPPED_LIVE system-config-users bug fix update 2007-05-01 14:42:32 UTC

Description David Lehman 2005-05-27 22:21:40 UTC
Description of problem:
s-c-users doesn't allow '.' in user/group names for new accounts. useradd does.
Please sync them up so people get consistent behavior. Here's what I think is
useradd's *intended* behavior:

* Wed Oct 27 2004 Adrian Havill <havill@redhat.com> 2:4.0.3-23.04
- conform to posix for user/group name input checking [def 3.426
  and 3.189] which is posix portable filename character set [3.276]
  while disallowing dash for first char as recommended, and disallow
  dollar sign)

NOTE: The above is from RHEL3 branch and was broken in the next shadow-utils; I
hope that was not a change of mind but rather an error.

Version-Release number of selected component (if applicable):
system-config-users-1.2.27-0.EL4.1

How reproducible:
Always

Steps to Reproduce:
1. create a user in s-c-users containing '.' (eg: "joe.schmoe")
2.
3.
  
Actual results:
s-c-users won't let you do it ("Please do not use punctuation in the user name.")

Expected results:
It should work according to POSIX.

Additional info:

Comment 1 Nils Philippsen 2005-06-10 18:54:19 UTC
This issue is the same as bug #141273 in Fedora Core.

Comment 6 Nils Philippsen 2005-10-31 17:05:45 UTC
*** Bug 172106 has been marked as a duplicate of this bug. ***

Comment 8 David Lawrence 2006-03-10 16:33:22 UTC
NEEDINFO_PM has been deprecated. Changing status to NEEDINFO and changing
ownership to pm manager.

Comment 9 Daniel Riek 2006-03-13 18:54:44 UTC
This would not have needed PM ACK as it is categorized as a bug.

A fix to this issue seems to be available and it is not unlikely that this
component will be included in a future Update release. 

Moving to the next Update, clearing all ACKs.

Comment 13 RHEL Product and Program Management 2006-08-18 17:39:02 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 15 Nils Philippsen 2006-08-29 08:20:47 UTC
*** Bug 204292 has been marked as a duplicate of this bug. ***

Comment 20 Red Hat Bugzilla 2007-02-08 19:21:00 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0071.html



Note You need to log in before you can comment on or make changes to this bug.