Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159034 - useradd not allowing '.' in usernames
Summary: useradd not allowing '.' in usernames
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: shadow-utils
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: David Lawrence
URL:
Whiteboard:
: 160469 (view as bug list)
Depends On:
Blocks: 168424
TreeView+ depends on / blocked
 
Reported: 2005-05-27 22:11 UTC by David Lehman
Modified: 2018-10-19 20:56 UTC (History)
4 users (show)

Fixed In Version: RHBA-2006-0032
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-15 15:32:19 UTC


Attachments (Terms of Use)
fix candidate (deleted)
2005-05-31 08:58 UTC, Peter Vrabec
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0032 qe-ready SHIPPED_LIVE shadow-utils bug fix update 2006-03-14 05:00:00 UTC

Description David Lehman 2005-05-27 22:11:46 UTC
Description of problem:
User/group names containing '.' are not allowed by U5 shadow-utils' useradd.
This is a regression. shadow-utils-4.0.3-23.04 seems to me to have it right but
it was broken again with -23.07.

Version-Release number of selected component (if applicable):
shadow-utils-4.0.3-23.08

How reproducible:
Always

Steps to Reproduce:
1. useradd joe.schmoe
2.
3.
  
Actual results:
useradd: invalid user name 'joe.schmoe'

Expected results:
Successful creation of account

Additional info:
Please re-examine the changes between -23.04 and -23.07 as I am fairly confident
they broke this and perhaps more.

Comment 1 Peter Vrabec 2005-05-31 08:58:34 UTC
Created attachment 114983 [details]
fix candidate

It's almost same patch as in RHEL-4 and devel.
Please let me now it works.

Comment 12 Milan Kerslager 2005-07-01 04:41:28 UTC
*** Bug 160469 has been marked as a duplicate of this bug. ***

Comment 15 Milan Kerslager 2005-10-11 18:16:47 UTC
After U6, the bug is still here. This is not so exciting as RHEL4 does not have
this bug and RHEL 2.1 does not have this bug too (and RHEL3 had not have this
bug in the past).

My (updated) patched packages are here:

ftp://ftp.pslib.cz/pub/users/Milan.Kerslager/RHEL-3/stable/
ftp://ftp.linux.cz/pub/linux/people/milan_kerslager/RHEL-3/stable/

Comment 21 Milan Kerslager 2005-11-01 09:03:34 UTC
Sorry - I did not used patch from comment #12 so '$' char has not been allowed.
New package is available from the URL above, auto-join to the Samba domain now
works.

Comment 24 Red Hat Bugzilla 2006-03-15 15:32:20 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0032.html



Note You need to log in before you can comment on or make changes to this bug.