Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159031 - eclipse is unable to find libxpcom.so
Summary: eclipse is unable to find libxpcom.so
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact:
URL:
Whiteboard:
: 159030 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-27 21:40 UTC by Bill Nottingham
Modified: 2014-03-17 02:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-24 14:54:12 UTC


Attachments (Terms of Use)

Description Bill Nottingham 2005-05-27 21:40:28 UTC
Description of problem:

On startup, eclipse prints:

ls: /usr/lib/mozilla-*/libxpcom.so: No such file or directory
ls: /usr/lib/firefox-*/libxpcom.so: No such file or directory
dirname: too few arguments

Version-Release number of selected component (if applicable):

3.1.0-fc-0.M6.22

How reproducible:

Every time

Steps to Reproduce:
1. run eclipse

Additional info:

Of course, on x86_64, those would be in /usr/lib64.

Comment 1 Bill Nottingham 2005-05-27 21:42:56 UTC
*** Bug 159030 has been marked as a duplicate of this bug. ***

Comment 2 Jeroen Beerstra 2005-08-08 01:48:35 UTC
Same here (also on x86_64 ofcourse), perhaps this is related to:

Plug-in "org.eclipse.swt.gtk" version "3.1.0" referenced by this feature is missing.

And some other messages like that: mentioned software seems to be available and
is not part of a separate rpm. Looks like the Eclipse shipped with FC4 x86_64 is
partially broken.

I'll file a separate bug report, it just seems to me all these messages are
related and probably easy to fix. 

 

Comment 3 Andrew Overholt 2005-08-24 14:54:12 UTC
I just committed a fix for this to rawhide.  When I finally get bug #151832
sorted out, I'll do an FC4 update that includes this fix.


Note You need to log in before you can comment on or make changes to this bug.