Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159013 - umount -f and -l don't actually work on a umount a hung NFS mount
Summary: umount -f and -l don't actually work on a umount a hung NFS mount
Keywords:
Status: CLOSED DUPLICATE of bug 149894
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: util-linux
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-27 17:55 UTC by Joshua Jensen
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-18 10:20:36 UTC


Attachments (Terms of Use)
patch to man (8) umount to indicate that soft, intr needs to be specified when using umount -f on NFS (deleted)
2005-06-20 15:35 UTC, Neil Horman
no flags Details | Diff

Description Joshua Jensen 2005-05-27 17:55:56 UTC
Description of problem:

Neither umount -f and -l (lower case "L") don't actually work to umount a hung
NFS mount.


# Here I have a hung NFS mount:
# strace df
...
stat64("/auto/andiamo", {st_mode=S_IFDIR|S_ISGID|0775, st_size=4096, ...}) = 0
stat64("/auto/dumpster4",
(hang)

# Here I try umount -f... notice that it just hangs:
# strace umount -f /auto/dumpster4
...
umask(022)                              = 022
getuid32()                              = 0
geteuid32()                             = 0
readlink("/auto", 0xbfff7920, 4096)     = -1 EINVAL (Invalid argument)
readlink("/auto/dumpster4",
(hang)

# Here I try umount -l... notice how it too hangs:
# strace umount -l /auto/dumpster4
umask(022)                              = 022
getuid32()                              = 0
geteuid32()                             = 0
readlink("/auto", 0xbfff8e40, 4096)     = -1 EINVAL (Invalid argument)
readlink("/auto/dumpster4",
(hang)



Version-Release number of selected component (if applicable):

RHEL3

Comment 1 Karel Zak 2005-05-28 06:42:57 UTC
Please, can you better describe method how you mount your NFS? Your problems are
typical for "hard" NFS mount. Some details you can found by "cat /proc/mounts".

man mount:

hard   The program accessing a file on a NFS mounted file system will hang when
the server crashes. The process cannot  be  interrupted  or killed unless you
also specify intr.  When the NFS server is back online the program will continue
undisturbed from where it was. This is probably what you want.

soft   This option allows the kernel to time out if the nfs server is not
responding for some time. The time can  be specified  with timeo=time.  This
option might be useful if your nfs server sometimes doesnât respond or will
be rebooted while some process tries to get a file from the server.  Usually it
just causes lots of  trouble.


Comment 2 Joshua Jensen 2005-05-31 15:30:56 UTC
Here are the options as mount shows them:

server:/dirname on /auto/sharename type nfs
(rw,rsize=32768,wsize=32768,tcp,hard,intr,addr=17.29.53.11)

Comment 3 Joshua Jensen 2005-06-07 20:42:59 UTC
So doesn't umount -f or -l not work with hard mounts?  If it doesn't, it should
be documented in the man page!

Comment 4 Neil Horman 2005-06-20 15:35:55 UTC
Created attachment 115699 [details]
patch to man (8) umount to indicate that soft, intr needs to be specified when using umount -f on NFS

Comment 5 Joshua Jensen 2005-06-20 16:44:40 UTC
I'm thinking that the "-l" option should also have this note attached to it too.

Comment 6 Joshua Jensen 2005-06-20 16:48:59 UTC
I'm thinking that the "-l" option should also have this note attached to it too.

Comment 10 Karel Zak 2005-07-18 08:18:53 UTC
Moving from "mount" to "util-linux" bugzilla component. The separate mount
package is in AS2.1 only. In RHEL3 we have util-linux.

Comment 11 Karel Zak 2005-07-18 10:20:36 UTC

*** This bug has been marked as a duplicate of 149894 ***


Note You need to log in before you can comment on or make changes to this bug.