Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159007 - RFE: Have CMAN detect use of loopback address and refuse to run
Summary: RFE: Have CMAN detect use of loopback address and refuse to run
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: cman
Version: 4
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Christine Caulfield
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-27 16:05 UTC by Lon Hohberger
Modified: 2009-04-16 19:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-17 14:40:53 UTC


Attachments (Terms of Use)

Description Lon Hohberger 2005-05-27 16:05:54 UTC
Description of problem:

When using 2-node clusters and /etc/hosts is improperly configured in such a way
that the local node name resolves to a loopback address, a split-brain can ensue.

Thus, it would be nice if, when starting, CMAN could check for the improper use
of loopback and abort/not run if this occurs (as well as printing a loud warning).

While the case where this would cause problems in production is probably
astronomically low (this is not a BUG, it's a feature request), it does and has
caused confusing for new installations when configuring the cluster for the
first time.

Comment 1 Lon Hohberger 2005-05-27 16:08:30 UTC
...it does and has caused confusion when configuring the cluster for the
first time.

Making sense is a good thing.



Comment 2 Markus Jeckeln 2005-05-27 16:23:42 UTC
Yes... my installation of RHEL 4 came up with my hostname in /etc/hosts at the
loopback address that came up with the cluster confusion. 

samples on node1

config sample: notworking
127.0.0.1               mynode1 localhost.localdomain localhost
192.168.0.105           mynode2
192.168.0.104           mynode1  #added by myself since i had probs with the cluster

config sample fixed & working
127.0.0.1               localhost.localdomain localhost
192.168.0.105           mynode2
192.168.0.104           mynode1

good thing would me a note in syslog or something like that

greeeeetz markus.jeckeln@gmx.de

Comment 3 Christine Caulfield 2005-05-31 15:08:49 UTC
Added to CVS head and FC4 branches.

Comment 4 Christine Caulfield 2005-06-28 12:37:19 UTC
Added to RHEL4 branch so it should appear in U2


Note You need to log in before you can comment on or make changes to this bug.