Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158997 - CAN-2005-1751 shtool insecure temporary file creation
Summary: CAN-2005-1751 shtool insecure temporary file creation
Keywords:
Status: CLOSED DUPLICATE of bug 159000
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: php
Version: 4.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard: impact=low,public=20050524,source=ven...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-27 15:27 UTC by Josh Bressers
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-27 15:48:25 UTC


Attachments (Terms of Use)

Description Josh Bressers 2005-05-27 15:27:23 UTC
Race condition in shtool 2.0.1 and earlier allows local users to
create or modify arbitrary files via a symlink attack on the
.shtool.$$ temporary file.
http://www.zataz.net/adviso/shtool-05252005.txt

php contains shtool in its source.

Comment 1 Josh Bressers 2005-05-27 15:27:49 UTC
This issue should also affect RHEL2.1 and RHEL3

Comment 2 Joe Orton 2005-05-27 15:48:25 UTC

*** This bug has been marked as a duplicate of 159000 ***


Note You need to log in before you can comment on or make changes to this bug.