Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158992 - pdf-viewers in FC can not correctly display, edit, save pdf-forms
Summary: pdf-viewers in FC can not correctly display, edit, save pdf-forms
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evince
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marco Pesenti Gritti
QA Contact:
URL: http://www.irs.gov/pub/irs-pdf/fw9.pdf
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-27 15:16 UTC by shrek-m
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-01 08:42:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 304575 None None None Never

Description shrek-m 2005-05-27 15:16:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.7.8-1.3.1

Description of problem:
try to display, edit, save forms in a pdf-form and you will see that only acroread >=5.1 can do this job correctly.
please enhance the included pdf-viewer or include acroread in future releases, at least in extras.

Version-Release number of selected component (if applicable):
evince 0.3.1-1

How reproducible:
Always

Steps to Reproduce:
1. try to edit and save a pdf-form with the fedora included pdf-viewer
(evince, xpdf, kpdf)
  

Actual Results:  nothing works as expected except acroread >=5.1

Additional info:

acroread <5.1 can edit but not save
acroread >=5.1 can edit and save
since a short time acroread 7.x is officilay available for linux
http://www.adobe.com/products/acrobat/readstep2.html
as tar.gz and rpm

$ pdfinfo fw9.pdf
Title:          Form W-9 (Rev. January 2005)
Subject:        Request for Taxpayer Identification Number and Certificate
Keywords:       Fillable
Author:         SE:W:CAR:MP
Creator:        OneForm Designer Plus
Producer:       Acrobat Distiller 6.0.1 (Windows)
CreationDate:   04-05-17
ModDate:        Tue Mar 15 07:22:47 2005
Tagged:         no
Pages:          4
Encrypted:      no
Page size:      612 x 792.008 pts (letter)
File size:      79195 bytes
Optimized:      no
PDF version:    1.3

Comment 1 David Woodhouse 2005-05-27 15:36:27 UTC
On a related note, if a form _has_ been edited in acroread, evince doesn't seem
to show the parts which were filled in. xpdf and kpdf do show those parts.

The form to which shrek-m refers is http://www.irs.gov/pub/irs-pdf/fw9.pdf

Comment 2 Marco Pesenti Gritti 2005-06-01 08:42:01 UTC
This is being tracked upstream.


Note You need to log in before you can comment on or make changes to this bug.