Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158988 - recompilation of imap-2002d failed with RHEL3 .src.rpm
Summary: recompilation of imap-2002d failed with RHEL3 .src.rpm
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: imap
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-27 14:46 UTC by Sebastien BLAISOT
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 19:01:27 UTC


Attachments (Terms of Use)

Description Sebastien BLAISOT 2005-05-27 14:46:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
When trying to recompile imap server rpm from redhat-provided src.rpm, the rpmbuild fails in the prep section because of RCS lock files included in source.

Version-Release number of selected component (if applicable):
imap-2002d-11

How reproducible:
Always

Steps to Reproduce:
1. download and install imap-2002d-11.src.rpm (up2date --get-source imap ; rpm -ivh /var/spool/up2date/imap-2002d-11.src.rpm)
2. cd to /usr/src/redhat
3. try to rebuild imap rpm (rpmbuild -ba SPECS/imap.spec)
  

Actual Results:  %prep section failed when patching sources :

+ patch -p0 -b --suffix .mbox-disable-patch -s
patch: **** File ./Makefile seems to be locked by somebody else under RCS
error: Bad exit status from /var/tmp/rpm-tmp.47208 (%prep)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.47208 (%prep)


Expected Results:  imap rpm built, no error

Additional info:

this error comes from the files 

imap-2002d/RCS/Makefile,v
and
imap-2002d/RCS/makefile.w2k,v

that are present in the imap-2002.tar.Z source file

Comment 1 Sebastien BLAISOT 2005-05-27 14:49:42 UTC
Workaround found :

launch
export PATCH_GET=0
before rpmbuild

Comment 2 RHEL Product and Program Management 2007-10-19 19:01:27 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.