Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158971 - DHCP client problem during KickStart Network installation
Summary: DHCP client problem during KickStart Network installation
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: dhcp
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-27 11:51 UTC by LinuxSystem
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-01 21:34:48 UTC


Attachments (Terms of Use)

Description LinuxSystem 2005-05-27 11:51:01 UTC
Description of problem:

dhclient-3.0pl2-6.14.i386.rpm is the original version of DHCP client that comes
with the RHEL 3 ES first CD. I tried to install via network, using KS, on two
different machines. Since KS uses DHCP client it tries to get IP address from
the DHCP server. The whole installation gets stuck at this very point of reading
an IP address and I have to start the whole installation again. If I set the
same IP address statically it works without any problem. To see if the IP
address was being assigned from the DHCP server - I checked the DHCP server's
lease file and it very well showed the whole details of the client's network
card even. It looks like the dhcp client that comes with the RHEL cd is very
weak. To double check on this, I tried running the DHCP client on an already
built but unupdated machine. It not only didn't take the DHCP IP address but it
made the network card module also corrupt. I had to remove the module and
reinsert it with modprobe or insmod.

dhclient-3.0.1-10_EL3 is the updated version which does not have any problem.

Version-Release number of selected component (if applicable):3.0pl2-6.14


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
DHCP client corruption

Expected results:
Proper DHCP client request handling

Additional info:

Please help!! :(

Comment 1 Jason Vas Dias 2005-05-27 16:03:18 UTC
dhclient-3.0.1-10_EL3 is the release on all the RHEL-3-U5 ES CDs - have you
tried using one of the latest ES CDs ?

With KS, what is important is the dhclient in the initrd.img you use for booting.
Where did that initrd come from ? If you base your initrd on the one from the
RHEL-3-U5 ES CDs, you should be getting dhclient-3.0.1-10 .

You say:
> I tried running the DHCP client on an already built but unupdated machine.
> It not only didn't take the DHCP IP address but it made the network card 
> module also corrupt.

dhclient has nothing whatever to do with network card driver module
installation. It sounds like the older machine just did not have the
correct drivers for or misconfigured them for the network card.

Please if possible append the initrd.img and ks.cfg that you 
use to this bug or send it to : jvdias@redhat.com .





Comment 2 Jason Vas Dias 2005-06-01 21:34:48 UTC
I have tested PXE boot with dhclient-3.0.1-10_EL3, and could find
no problems. Closing as non-reproducible.


Note You need to log in before you can comment on or make changes to this bug.