Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158949 - rc.sysinit should re-initialize LVM2 after mdadm -A -s
Summary: rc.sysinit should re-initialize LVM2 after mdadm -A -s
Keywords:
Status: CLOSED DUPLICATE of bug 149514
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts
Version: 4.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-27 01:29 UTC by David Kewley
Modified: 2014-03-17 02:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-27 02:41:41 UTC


Attachments (Terms of Use)

Description David Kewley 2005-05-27 01:29:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux; en_US) KHTML/3.4.0 (like Gecko)

Description of problem:
rc.sysinit does things in this order:  
  
echo "raidautorun /dev/md0" | nash --quiet  
# LVM2 initialization  
# LVM initialization  
if [ -f /etc/mdadm.conf ]; then  
    /sbin/mdadm -A -s  
fi  
if [ -f /etc/raidtab ]; then  
    ... start up raid  
    # LVM2 initialization, take 2 
    # LVM initialization, take 2 (it could be on top of RAID) 
fi 
 
The result is that LVM2 logical volumes (or LVM I presume) that are on top of 
mdadm-managed raid volumes do not get initialized.  My solution so far is to 
re-run the LVM2 initialization in rc.local.  I think it should instead be done 
in rc.sysinit. 
 

Version-Release number of selected component (if applicable):
7.93.11.EL-1

How reproducible:
Always

Steps to Reproduce:
1. make a LVM2 logical volume (&PV,VG) on top of a mdadm-managed raid device 
2. reboot 
 
   

Actual Results:  The new logical volume is not initialized -- it does not appear in /dev. 
 

Expected Results:  The new logical volume should be usable immediately after boot -- it should be 
initialized during the boot process, which makes it shows up in /dev. 
 

Additional info:

Comment 1 Bill Nottingham 2005-05-27 02:41:41 UTC

*** This bug has been marked as a duplicate of 149514 ***


Note You need to log in before you can comment on or make changes to this bug.