Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158933 - Evolution's Exchange account UI allows you to enter mailboxes with @ characters in them.
Summary: Evolution's Exchange account UI allows you to enter mailboxes with @ characte...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution-connector
Version: 4.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 145411
TreeView+ depends on / blocked
 
Reported: 2005-05-26 23:24 UTC by Dave Malcolm
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-17 16:03:45 UTC


Attachments (Terms of Use)

Description Dave Malcolm 2005-05-26 23:24:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
It's quite difficult to set up the Evolution connector properly

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start Evolution with evolution-connector installed
2. Start creating a new Exchange account
3. In the 2nd Receiving Email dialog, mistakenly enter your email address e.g. "john.doe@example.com" rather than "john.doe"
  

Actual Results:  Evolution allows you to do this, and fails with a dialog saying: "Could not find Exchange Web Storage System at http://SERVER-NAME/exchange/john.doe@example.com/.
If OWA is running on a different path, you must specify that in the
account configuration dialog."

Expected Results:  Evolution should either:
(i) strip off the @ and subsequent characters
(ii) complain about them and not allow such input
(iii) have a UI of the form:    [text entry box] [label saying: @domainname]
making it clearer what's going on.

Additional info:

Comment 1 Dave Malcolm 2005-05-26 23:27:41 UTC
Step 3 above should read:
In the 2nd Receiving Email dialog, for the "Mailbox" field, mistakenly enter
your email address rather than the mailbox name e.g. "john.doe@example.com"
rather than "john.doe"

Comment 6 Dave Malcolm 2005-06-17 16:03:45 UTC
As it turns out, I was wrong about this; we encountered a customer site where
some of the mailbox names do indeed contain "@" characters - and some don't.

The bug here is really "the connector is far too hard to set up manually".  The
ximian-connector-setup tool makes it far easier, and we probably should
recommend using this, and provide an automated version of it for mass deployments.

Closing this as NOTABUG; I'll open up another bug suggesting a better way of
doing configuration




Note You need to log in before you can comment on or make changes to this bug.