Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158914 - Un-initialized "device" in ping.c and ping6.c
Summary: Un-initialized "device" in ping.c and ping6.c
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iputils
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Radek Vokal
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 156322
TreeView+ depends on / blocked
 
Reported: 2005-05-26 19:33 UTC by Wendy Cheng
Modified: 2010-10-22 03:02 UTC (History)
1 user (show)

Fixed In Version: RHBA-2005-610
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-05 15:44:18 UTC


Attachments (Terms of Use)
Patch for this issue. (deleted)
2005-05-26 19:33 UTC, Wendy Cheng
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:610 qe-ready SHIPPED_LIVE iputils bug fix update 2005-10-05 04:00:00 UTC

Description Wendy Cheng 2005-05-26 19:33:36 UTC
Created attachment 114881 [details]
Patch for this issue.

Comment 1 Wendy Cheng 2005-05-26 19:33:36 UTC
Description of problem:

The problem was first reported as an IA64 kernel issue where the message of
"unaligned access" is written in /var/log/messages when ping & ping6 is executed as:
                                                                               
   ipf03 kernel: ping(4893): unaligned access to 0x60000fffffffbbd6,
ip=0xa000000100447b40
or
ipf03 kernel: ping6(8196): unaligned access to 0x60000fffffffbbd5,
ip=0xa000000100447b40
                                                                                
Further looking into the issue, it was found the messages were generated by user
mode option passed into sock_setsockopt() kernel call. This led to the
un-initialized "device" global in ping.c and ping6.c.
                                                                                
Patch also uploaded - drafted by me and tested out by the customer.


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes - depending on whatever garbage value stays in the "device" variable. 
 
Steps to Reproduce:
* Execute ping command with -I option.
    #ping -I eth0 10.124.201.2

  
Actual results:
* Look at /var/log/messages
  #view /var/log/messages
  ipf03 kernel: ping(4893): unaligned access to 0x60000fffffffbbd6,
ip=0xa000000100447b40

Expected results:
No error messages in /var/log/messages file.

Additional info:
Though symptom are easily shown up in IA64 machines, this is not arch-dependent bug.

Comment 8 Red Hat Bugzilla 2005-10-05 15:44:18 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-610.html



Note You need to log in before you can comment on or make changes to this bug.