Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158895 - Unable to 'xm save' domU
Summary: Unable to 'xm save' domU
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xen
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rik van Riel
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 158899
TreeView+ depends on / blocked
 
Reported: 2005-05-26 16:52 UTC by AJ Lewis
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-31 16:16:49 UTC


Attachments (Terms of Use)
strace of 'xm save oxygen ./oxygen.xen' (deleted)
2005-05-26 16:53 UTC, AJ Lewis
no flags Details

Description AJ Lewis 2005-05-26 16:52:22 UTC
Description of problem:
I get an error when trying to run 'xm save dom dom.xen'

Version-Release number of selected component (if applicable):
xen-2-20050522
kernel-xen0-2.6.11-1.1363_FC4
kernel-xenU-2.6.11-1.1363_FC4

How reproducible:
Every time

Steps to Reproduce:
1. Boot xen kernel
2. start xen domU
3. run 'xm save domain_name somefile'
  
Actual results:
Error: Internal Server Error

Expected results:
domU gets state saved into specified file and is suspended

Additional info:
migrating to localhost also fails.
# xm migrate oxygen localhost
Error: Internal Server Error

xfrd is running:
# ps ax | grep xfrd
 2399 ?        S      0:00 xfrd

I'll attach a backtrace as well

Comment 1 AJ Lewis 2005-05-26 16:53:38 UTC
Created attachment 114877 [details]
strace of 'xm save oxygen ./oxygen.xen'

Comment 2 AJ Lewis 2005-05-26 17:01:51 UTC
Hrm...looks like I can make it work by creating the directory
/var/lib/xen/xen-db/migrate - any reason that isn't created by the rpm?

Comment 3 Rik van Riel 2005-05-26 17:35:36 UTC
The RPM doesn't have that directory because it's not created by the "make
install" command that the spec file runs.

*sigh*

Guess I'll send some fixes upstream, as well as fixing it in the FC4 RPM...

Comment 4 Rik van Riel 2005-05-30 15:02:40 UTC
A fix for this issue was added to today's Xen RPM, 2-20050530

Comment 5 AJ Lewis 2005-05-31 15:37:43 UTC
Verified xen-2-20050530 corrects this issue.


Note You need to log in before you can comment on or make changes to this bug.