Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158892 - ccsd crashes if asked for values from a node with no children
Summary: ccsd crashes if asked for values from a node with no children
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: ccs
Version: 4
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 158891
TreeView+ depends on / blocked
 
Reported: 2005-05-26 16:28 UTC by Lon Hohberger
Modified: 2009-04-16 20:17 UTC (History)
1 user (show)

Fixed In Version: RHCS4U1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-22 20:01:21 UTC


Attachments (Terms of Use)
Fixed behavior (deleted)
2005-05-26 16:28 UTC, Lon Hohberger
no flags Details | Diff

Description Lon Hohberger 2005-05-26 16:28:16 UTC
Description of problem:

Fenced was asking for this from ccsd in order to see if the local node
name was present in the cluster configuration:

    /cluster/clusternodes/clusternode[@name="cyan"]

Unfortunately, because there were no children of that XML node (no
fencing configured), ccsd was crashing.

Version-Release number of selected component (if applicable):
-RHEL4U1 -RHEL4 -RHEL4


How reproducible: 100%

Steps to Reproduce:
1. Create configuration with no fencing specified for a node.
2. Start ccsd on that node.
2. Start fenced on that node.
  
Actual results:
ccsd crashes (SIGSEGV)


Expected results:


Additional info:

This fix is dependent on a fix to ccsd which prevents it from crashing in this case.

Comment 1 Lon Hohberger 2005-05-26 16:28:17 UTC
Created attachment 114875 [details]
Fixed behavior

Comment 2 Lon Hohberger 2005-05-26 16:58:30 UTC
Patches in CVS


Note You need to log in before you can comment on or make changes to this bug.