Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158890 - special chars in man output even when TERM=dumb
Summary: special chars in man output even when TERM=dumb
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: groff
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-26 16:26 UTC by Jonathan Kamens
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-25 16:30:15 UTC


Attachments (Terms of Use)
"man man | col -b" output (deleted)
2005-05-30 20:52 UTC, Jonathan Kamens
no flags Details

Description Jonathan Kamens 2005-05-26 16:26:48 UTC
If I run M-x man RET perlvar RET in Emacs, the resulting file has all kinds of 
trashy special characters in it.  I assume that Emacs is telling man to format 
for a dumb terminal, but it doesn't appear to work.  If I run "TERM=dumb man 
perlvar" in a shell I see the same thing -- the resulting output has special 
formatting characters in it.  I've got all current FC devel packages.

Comment 1 Ivana Varekova 2005-05-27 08:52:42 UTC
Hello,
could you please attach here your man output. Thank you.


Comment 2 Jonathan Kamens 2005-05-30 20:49:11 UTC
It looks like it's outputting unicode.  I'll attach an example.  Here are my
related environment variables:

LANG=en_US.UTF-8
LC_COLLATE=C

I added a Perl script to Man-filter-list to get rid of the annoying characters.
 Here's what it does:

#!/usr/bin/perl

while (<>) {
    1 while (s/[^\010]\010//g);
    s/\342\224\202/\|/g;
    s/\342\224\|/\|/g;
    s/\342\200\234/\"/g;
    s/\342\200\235/\"/g;
    s/\342\200\231/\'/g;
    s/\342\200\'/\'/g;
    s/\342\200\230/\`/g;
    s/\302\302\267/*/g;
    print;
}


Comment 3 Jonathan Kamens 2005-05-30 20:52:03 UTC
Created attachment 114976 [details]
"man man | col -b" output

See, for example, the unicode characters in the "manpage" NAME line at the top.

Comment 4 Miroslav Lichvar 2006-01-25 16:30:15 UTC
Your locale is set to UTF-8, therefore groff will output unicode characters
(such as the U+2019 for apostrophe). It is not a bug.


Note You need to log in before you can comment on or make changes to this bug.